Subscribe

Citrix and lun pathing

Hi guys,

Having assigned to a some blades running xen citrix some luns.

I have enabled ALUA

When I run: igroup show

on first filer:

  Xen_Desktop (FCP):

        OS Type: xen

        Member: 50:01:43:80:04:26:3f:cc (logged in on: vtic, 0b)

        Member: 50:01:43:80:04:26:3f:ce (logged in on: vtic, 0d)

        Member: 50:01:43:80:04:26:41:10 (logged in on: 0b)

        Member: 50:01:43:80:04:26:41:12 (logged in on: 0d)

on second:

Xen_Desktop (FCP):
    OS Type: xen
    Member: 50:01:43:80:04:26:3f:cc (logged in on: vtic, 0b)
    Member: 50:01:43:80:04:26:3f:ce (logged in on: vtic, 0d)
    Member: 50:01:43:80:04:26:41:10 (logged in on: vtic, 0b)
    Member: 50:01:43:80:04:26:41:12 (logged in on: vtic, 0d)

1/Is it possible to force a host to shoose a path?

2/As my zoning look ok and on xen center a see 4 path for each lun what could be the errors?

Re: Citrix and lun pathing

I had a similar problem with XenServer and XenCenter, seems like XenCenter sometimes displays the wrong information. Use the embedded HBA tools on XenServer to get the accurate information. By default XenServer uses round-robin.

Qlogic HBA tool:

/opt/QLogic_Corporation/SANsurferCLI/scli

Emulex HBA tool:

/usr/sbin/hbanyware/hbacm

Cheers.

Re: Citrix and lun pathing

found on citrix doc and i think it should be done on netapp both filer

Configuring Multipathing for Fiber Channel

1. Open a console session to the NetApp active-active controller configuration, set igroup to ALUA.

igroup set <initiator_group> alua yes

igroup show –v

2. Modify /etc/multipath-enabled.conf file to include the following in the devices section

defaults

{

user_friendly_names no

max_fds max

queue_without_daemon no

}

devices

{

device{

vendor "NETAPP"

product "LUN"

getuid_callout "/sbin/scsi_id -g -u -s /block/%n"

prio_callout "/sbin/mpath_prio_alua /dev/%n"

features "1 queue_if_no_path"

hardware_handler "0"

path_grouping_policy group_by_prio

failback immediate

path_checker directio

flush_on_last_del yes

}

}