Subscribe

Snapshots not commiting and failing to backup

Hi All

I have seen such post before on this platform and I thought I must explain my situation.

FAS 3040, NFS, ISCSI, Proliant 460c, ESX3.5U4, SMVI v1.2, 4 datastores, 4 SMVI Jobs for each datastore, Virtual Vcenter 2.5 U4 server on 5th datastore

I have few issues with SMVI.

1. it randomly will not backup some Ctrix servers (servers are not busy) and couple of app servers. unable to commit snaps. I have implemented best practices around that. have not installed EHU yet. everyday I will have atleast 3 servers failing. don't know where error is? who do I need to talk VMWARE or NETAPP??

2. some time backup job status will say "running" but it has finished. I have been told a trick, stop SMVI service and rename crash folder. I have done this 3 times in less than a month of installation. is there any patch which can fix this issue or something I need to do to help the situation?

3. cannot restore a vm using SMVI which has Snaps attached to it. I have tested 2 times and machine which has snaps attached restore will fail with an error. do you know, if I cannot restore VM which has snaps attached and this is how SMVI works?

thanks a lo for help

Regards

Ajay

Re: Snapshots not commiting and failing to backup

Anyone....

Re: Snapshots not commiting and failing to backup

Abjay,

You have likely seen to that the failure to close snaps usually indicates something on the ESX side of things is struggling. Can you open and close snaps from vCenter with no problems (that will let you know where the problem lies? How many VMs are in the backup job? Do these VMs have existing snapshots?

How are your ESX servers configured? That is how much memory do you have assigned to the service console and how busy are they? You might be able to improve this by increasing the amount of memory the SC has. VMware has a few recomendation for improving VMware snapshot performance also so I would check those out.

Some food for thought, for Citrix servers you may not need VMware snaps. That is, you could remove the Citrix boxes and any other boxes that don't need the VMware quiecing from the backup job and then schedule a second job without VMware snaps. The VMs will only be crash consistent but you will place zero load on the VMware environment and still have full recovery functions.

If you need the VMware snaps then I recommend breaking the backup job into 2 parts and dividing the VMs between the jobs, this will likely reduce the load on the ESX servers and might make things go more smoothly.

Hopefully that helps.

Keith

Re: Snapshots not commiting and failing to backup

Hi keitha

thanks a lot for your comments. I am also suspecting that we do have issue with SC memory, I checked once in a day time and only 12MB memory was free, we have default 272 (i think) assigned. someone did not do job properly!! Currently we are not taking VM snapshots with SMVI, so replying on crash consistent state...

other issues I come across with SMVI was, 1 restore says it is finished but in the back ground it is stil restoring and restore fails if restore VM with snapshots attached, these have been addressed in 1.2R1.

thanks

Ajay

Re: Snapshots not commiting and failing to backup

Great to hear Ajay. A few other tips I have come across since this post too is be sure your VMware tools are upto date! Out of date VMware tools can cause problems such as this. Also if you have one VM which keeps failing try a repair of the VMware tools as I have found that sometimes cures the problem.

Finally SMVI 2.0 will be out soon and within in we can tune the number of concurrent snapshots which also can improve the VMware snapshot success. Definitely though increasing the SC memory will help.

Keith

Re: Snapshots not commiting and failing to backup

Hi Keitha

thanks for your comments. do you know when version SMVI 2 would be out?

Cheers

Re: Snapshots not commiting and failing to backup

Install EHU asap mate. it should improve your success rate. also make sure there are no misalignment issues as that can impact SMVI.

Let me know if you need help identifying misalign. issues.

cheers,

Eric

Re: Snapshots not commiting and failing to backup

Hi Eric

thanks for your comments, I thought of doing it as best practices recommends it, can you please advise what benifits I am suppose to get it from EHU, any doc for reading on this? also Do I need to have Data fabric manager for this? where can I get more info on misalignment, I suppose you are talking about Guest OS alignment??

any news about SMVI 2.0??

thanks

Ajay

Re: Snapshots not commiting and failing to backup

Hi Ajay,

THe info you need is under product information on now.netapp.com

http://now.netapp.com/NOW/knowledge/docs/hba/iscsi/esx/iscsi_esx_hu_31/html/software/rnote/index.shtml

The download is here:

http://now.netapp.com/NOW/cgi-bin/software/?product=iSCSI+Host+Utilities&platform=ESX

You dont need a license for this as far as I know, you dont even need DFM. Here is info with regards to misalignment.

http://media.netapp.com/documents/tr-3747.pdf

Eric