Subscribe

fas3140 disk errors on running traffic.

Hi All,

I am using fas3140 with controllers enabled in failover mode (in case). On one of the controller (to which I will be running most of the traffic), I have created a separate volume (say /vol/xxyy) other than the root vol. Once the volume and LUNs(around 150 of size 2g each) are created and mapped to my igroup, I started running traffic from my FCoE initiator. It is observed that after sometime the filer started reporting errors saying three disks on that controller's bay are being broken and failover mode in kicks and the other controller takes over.

Why is this happening? I removed those three disks and started running traffic, It ran fine for couple of days but again I see few more discs being reported as byte segment failed,excessive errors encountered or scsi transport command failed and failover occurs. Is my config wrong or the discs have just gone bad?.

Cheers,

Somu

Re: fas3140 disk errors on running traffic.

Do you have a support contract? That sounds like something that may need an ONTAP software/firmware update. You did not state how much traffic (production or stress testing), if you are using ALUA or anything like that, but there have been bugs in the past that are related to out of date firmware under stress. Your AutoSupport or a quick review of the release you are running should show you if there are issues. There should be no reasonable reason for multiple disks to come offline in a group like that, so looking for updated firmware on your trays and errors in the NetApp about any communication problems with the disk trays would be good.

Re: fas3140 disk errors on running traffic.

Thanks for the reply. Yes I am running heavy stress. AutoSupport feature was disabled(although I thought it will be enabled by default) and regarding the software, ONTAP software was upgraded to 8.0.2 couple of days back. I shall upgrade the firmware on the tray ASAP and let you know how it's working. hopefully it fixes the issue.

Cheers,

Somu

Re: fas3140 disk errors on running traffic.

Ausotusupport is enabled by default, but you have to configure how it is delivered (HTTPS or SMTP). By default it is set to HTTPS and it is very unlikely that your appliance has direct connection to Internet. So you need to either set up proxy connection, or change to SMTP and define mail server, return address etc.

Re: fas3140 disk errors on running traffic.

Thank you for the information . Much appreciated. I am trying to download the shelf firmware. Is there anyway to extract the current firmware being installed? I did a "storage show disk -a <discname>" and got the disk details but could not get shelf firmware that is currently installed.

Thanks,

Somu

Re: fas3140 disk errors on running traffic.

sysconfig -v