Subscribe
Accepted Solution

Agent Monitor - Agents statuses all down

[ Edited ]

Hello Experts,

I am just starting to use SMSP. I configured my Manager and installed the various agents (control and members)

When I open the SMSP interface and go to Control Panel - SMSP Services - Control Service, I can see at the SErver Monitor that it is up but when I go to the Agent Monitor tab, all the agents have status of down. I know that the communication service on the agents are running. I did restart the service and it went up, but then it would go back down when I look at the Agent Monitor.

What am I doing wrong here?

Thanks,

Maico

Re: Agent Monitor - Agents statuses all down

Maico,

Here are some common causes of Agent communication problems:

1. Windows/network firewall blocking the agent communication ports

2. Port configuration mismatch between the Agents and the Management server

3. Port collision some other application (such as DocAve) is using the ports that the Agents are configured to use

4. Name resolution of the Server Manager on the Agent not working.

Thanks,
Mark

Re: Agent Monitor - Agents statuses all down

Mark,

I tested the connections and they all connected to the control service of the manager successfully. There is no contention on the port also with other application.

Thanks for the advise.

Maico

Re: Agent Monitor - Agents statuses all down

Also what I notice is, when I restart the agent service, I will then see in the manager that the status is up but then will be down again after a few seconds, although on the actual server (agent), the service is still running.

Re: Agent Monitor - Agents statuses all down

Maico,

Please configure the management server to use an IP address for the control service, media service, and web service. You can do this via the Management Server Configuration tool that is found in the All Programs > NetApp > SnapManager for SharePoint program group.

Also, please change the Agents to use IP addresses for the control service address and the agent address. There is an Agent Configuration tool that is found in the All Programs > NetApp > SnapManager for SharePoint program group.

Also, please check the firewall settings on the Management server as well as the hosts where the SMSP agents are installed.

On the SMSP Managment server these ports need to be open:

SMSP Control Service Port 12000

SMSP Manager Web Service Port 12011

SMSP Media Service Control Port 12001

SMSP Web Service Port 8080 or 8443

Make sure that the Management server can communicate to the NetApp storage over port 80, 443, and 135.

On the server where the SMSP Agent is installed, these ports need to be open:

SMSP Control Service Port 12000

SMSP Agent Port 10103

SMSP Archiver Port 10107

Thanks,
Mark

Re: Agent Monitor - Agents statuses all down

Mark,

Thank you, your suggestion resolved it for me!

Maico

202.403.5204 (Office)

202.445.3640 (Mobile)

Re: Agent Monitor - Agents statuses all down

Mark,

So after successfully installing the agents, I created a logical device. I am now at a point that I can run a test backup . I go to Backup builder and this is what I see for the option.

Farm: farm(SP_SQL server_name: Sharepoint_config)

Agent: CentralAdminServer

So I try to run a job with just the basic settings. It failed with this message:

SMSQL or SnapDrive version error: IndexServerName: CentralAdminServer SnapDrive is not installed

Statistical Result: 1 MB data, 0(0) site collections, 0(0) sites, 0(0) lists, 0(0) items

I don’t understand why it is saying that the WFE that has the Central Administration is the Index Server because we don’t use the SP Index server.

Thanks again for walking me through all this process.

Maico

Re: Agent Monitor - Agents statuses all down

Maico,

SharePoint Search consists of the SharePoint Index and the SharePoint database servers. They are backed up and restored as a set.

If you don't have the SharePoint Search Index data on a NetApp LUN managed by SnapDrive, you will get this error.

If you don't want to protect the SharePoint Search data, just exclude the index data and the Search database in the SMSP backup plan.

Thanks,
Mark