Subscribe

Backup finished with exception - an error occurred while generating the index

[ Edited ]

Hi everyone,

 

I'm using SMSP 8.2 for backing up our Sharepoint 2013 environment which consists of

- Server 1 (Server 2012 R2): Sharepoint-Server, SMSP Agent and Snapdrive 7.1 installed.

- Server 2 (Server 2012 R2): SQL Server (2012) with SMSP Agent, Snapdrive 7.1 and SMSQL 7.2 installed.

- Server 3 (Server 2012 R2): SMSP Server, SnapDrive 7.1 installed and mounted LUN for Backup data.

 

The Job monitor logs with status "finished with exceptions".

Details tell me:

Type: Item Index

Source_Name: WSS_Content

Status: Failed

Comment: An error occured while generating the index. An error occured while cloning the temporary database. Details: WSS_Content.

 

The content database (WSS_Content) itself is being backuped successfully.

 

Thanks in advance.

Marius

Re: Backup finished with exception - an error occurred while generating the index

[ Edited ]

During backup the following two errors occure in the sql server eventlog:

 

SMSP8 Agent Service Error ID 8101

Failed to execute the command.
 Parameter:  clone-backup -Server "s2001" -ServerInstance "S2001\SHAREPOINT" -Database 'WSS_Content' -TargetDatabase 'BAK_2E86B77CDD4CA3F4203A746885BAE27464747ED2_20151123085453' -TransLogsToApply 0 -TargetServerInstance "S2001" -Backup "sqlsnap__s2001_11-23-2015_08.54.44" -ForceRestore:$True -RecoverDatabase:$True -apicontext:$True -verbose:$True
 Command Name:  clone-backup
 Cause: ExistedErrorMessageWhenExecuteCommandException: An error occurred while executing the command.
 Error Message: Pipeline State Changed to Failed:
The database 'WSS_Content' from SQL server instance 'S2001\SHAREPOINT' was not found in the backup 'sqlsnap__s2001_11-23-2015_08.54.44' to be restored.

 More Information: http://www.avepoint.com/community/event-id/?id=8101

 

SMSP8 Agent Service Error ID 8407

Failed to operate the database.
 Database Name:  System.String[]
 Database Type:  Temp Database
 Operation Type:  Mount
 Cause: ExistedErrorInSMSQLException: An error occurred in SMSQL.
 Error Message: Clone database failed.

 More Information: http://www.avepoint.com/community/event-id/?id=8407

 

 

Edit: I've separated the indexing job, but the job fails with the same errors. If I backup without granularity (so no index needs to be created) the backup is successful.

Re: Backup finished with exception - an error occurred while generating the index

Hi,

 

This might be related to http://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=869173, please call support.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Backup finished with exception - an error occurred while generating the index

Hi,

 

Did you get a fix for this?

 

Thanks