Subscribe
Accepted Solution

Can't get perfstat to work with Windows 7, plink and RLM prompt.

I'm trying to use perfstat with Windows 7 and plink but I can only get to the RLM prompt and then I receive "command not found".

This is what I receive:

C:\>plink -ssh -l <user.name> -pw <> <ip>

Using user.name "<user.name>"

Lastlogin: Blah blah blah

RLM <host name>> perfstat -f <hostname> -t 5 -i 12 -l user.name  -S pw: <> > report.out

command contains an illegal sequence beginning at ">"

I then try it without ">"

RLM <host name>> perfstat -f <hostname> -t 5 -i 12 -l user.name -S pw: <>

command not found. Type '?' for a list of available commands.

When I need to get into dataONTAP I also have to enter "system console" and then login with username and pw again. I know I'm not in the correct area for the perfstat command but I don't know where I should be... can anyone help?

Re: Can't get perfstat to work with Windows 7, plink and RLM prompt.

a) perftstat is the command you run on your host (Windows 7 in this case), not on your filer

b) you cannot run perfstat via RLM, filer must be connected to LAN and you must be able to SSH into it from Windows host

See https://kb.netapp.com/support/index?page=content&id=1010551 for a description how to invoke perfstat over plink. Make a search for “perfstat plink” to get even more …

Re: Can't get perfstat to work with Windows 7, plink and RLM prompt.

Thank you! That article is exactly what I needed! I also needed to enable SSH on my filer first. I thought because I could SSH through putty to the RLM SSH was already enabled but I was mistaken.

It's working great now!