Subscribe
Accepted Solution

Cannot restore or clone databases in SMSQL

[ Edited ]

I need to clone a database from several days ago to compare some data.  My problem is that none of the databases are available in the restore tree on SnapManager for SQL.  All the backups and transaction logs say that they've competed successfully but the restore pane is simply blank.  Running the clone or restore wizard fails to list any of the backed up databases.

 

I'm running SMSQL 7.2.0.2184 with snapdrive 7.1 on windows 2012 R2.

Re: Cannot restore or clone databases in SMSQL

[ Edited ]

I think I've got a bigger problem here.  Looking at snap drive, each of the LUNs that I map to, SQL_DB, SQL_Logs, SQL_Sys, and SQL_SnapInfo are mapped three times each.  I cannot figure out why this occurred.

 

After hours I stopped SQL services and forced a disconnection of each lun, which one disconnect disconnected all three mappings.  I then re-mapped the luns, one-by-one then rebooted the server and SQL came up just fine, but again each LUN was mapped three times.

 

Every attempt at backups now result in the error: "Snapdrive was unable to create a snapshot copy of one or more luns that reside on different system volums.  All snapshot copies that were created as part of this lun snapshot copy were deleted.  The check the application event log.  SnapDrive error code 0xc00402c2.

 

 

Why are luns mapped three times each?  I cannot find anything unusual.  Why did my backups break?

 

Getting worried because now I cannot backup or restore production databases.

 

UPDATE: The backups are now working.  Basically I had it the limit of snapshots on my volumes.  After cleaning up old snapshots, the backups are working again, but still I'm not able to do restores.  I have a case open with NetApp on this issue.

Re: Cannot restore or clone databases in SMSQL

After working with NetApp support a resolution to this issue was found.

 

Basically it all comes down to version compatibility.  I was running too new of versions of SnapDrive and SMSQL for the version of ONTAP of my filers.

 

After downgrading snapdrive and SMSQL backups and restores of my production databases are now working.

 

Turns out that the backups were never working despite the fact the email notification I received said that they were backed up successfully.

 

Moral of the story is check the compatibility matrix.