Subscribe

Error executing snapshot with SAP_ORACLE module via snapcreator 3.5

[ Edited ]

Hello everbody,

i`ve got the following error message when executing a snapshot with snapcreator 3.5 incl. SAP_ORACLE module:

14 [Fri Mar 30 14:34:08 2012] ERROR: /addon/snapcreator/scAgent3.5.0/plugins/native/SAP_ORACLE: line 14: package: command not found 15 /addon/snapcreator/scAgent3.5.0/plugins/native/SAP_ORACLE: line 16: syntax error near unexpected token `(' 16 /addon/snapcreator/scAgent3.5.0/plugins/native/SAP_ORACLE: line 16: `our @ISA = qw(SnapCreator::Mod);' 17 [Fri Mar 30 14:34:08 2012] [dbi92-se:9090(3.5.0.1)] ERROR: [scf-00053] Application quiesce for plugin SAP_ORACLE failed with exit code 512, Exiting! 18 19 ########## Application unquiesce ########## 20 [Fri Mar 30 14:34:08 2012] ERROR: /addon/snapcreator/scAgent3.5.0/plugins/native/SAP_ORACLE: line 14: package: command not found 21 /addon/snapcreator/scAgent3.5.0/plugins/native/SAP_ORACLE: line 16: syntax error near unexpected token `(' 22 /addon/snapcreator/scAgent3.5.0/plugins/native/SAP_ORACLE: line 16: `our @ISA = qw(SnapCreator::Mod);' 23 [Fri Mar 30 14:34:08 2012] ERROR: [scf-00054] Application unquiesce for plugin SAP_ORACLE failed with exit code 512, Exiting! Can anybody pls. give me a hint where to find the error? Environment: scServer 3.5 scAgent 3.5 OS: SLES 11 for Server and Agend Oracle-Version 11.2 SAP-Module: SAP_ORACLE.pm Regards Ralph

Re: Error executing snapshot with SAP_ORACLE module via snapcreator 3.5

Hi,

This is a bug or error in SAP_ORACLE plugin. Where did you get this plugin? Did you create it? Whois author?

I am guessing problem may be this plugin is perl. If so and it is using perl-style you need to add plugins under /plugins/SAP_ORACLE/SAP_ORACLE.pm. This is only if it is perl class.

Otherwise if it is a .pl or other language under /plugins/native

If you share plugin we can help debug further

Also if you are interested in plugin dev you should join SC dev community www.snapcreator.com.

Regards,

Keith