Subscribe

Frequent Recovery Point - Passive Node Issues

We run 2 types of backups at out company:

1) Daily Backups

"D:\Program Files\NetApp\SnapManager for Exchange\SMEJobLauncher.exe" new-backup -Server 'EVS' -CCRActiveNode $False -ManagementGroup 'Standard' -NoTruncateLogs $False -RetainBackups 4 -StorageGroup 'First Storage Group','Second Storage Group','Third Storage Group','Fourth Storage Group','Fifth Storage Group','Sixth Storage Group' -Verify -VerificationServer 'cgyprdccr02' -UpdateMirror -BackupCopyRemoteCCRNode $False

2) Frequent Recovery Point Backups

"D:\Program Files\NetApp\SnapManager for Exchange\SMEJobLauncher.exe" new-backup -Server 'EVS' -CCRActiveNode $False -NoTruncateLogs $False -StorageGroup 'First Storage Group','Second Storage Group','Third Storage Group','Fourth Storage Group','Fifth Storage Group','Sixth Storage Group' -RecoveryPoint -UpdateMirror

Job #1 works perfectly fine and keeps 4 online copies on the PROD filer....it also snapmirrors to the DR Filer. Backups are ran from the Passive Node

Job #2 works perfectly fine on the Passive node. It adds the FRP logs to the SnapInfo directory for each respective storage group. The problem is that it also adds the FRP logs to the SnapInfo directory on the Active node??

This causes issues with our Backup and Recovery strategy, as we never run backup jobs on the Active Node. This means that the SnapInfo Directory continues to grow, and the SnapInfo Logs never become purged!

Is this a known issue with SME 5.0?

Has anyone seen this in the past?

Re: Frequent Recovery Point - Passive Node Issues

Hi Todd...

I'm doing a bit of investigating on this issue. I wanted to first be absolutely clear on what you're seeing. Here's my summary...

- Performing FRP backup on the passive node

- Logs are getting moved into the SnapInfo dir correctly on that node

- Logs are also getting moved into the SnapInfo dir on the active node

- No backups are running on the active node, therefore no log truncation after the backup is complete

Is that a good summary? Anything I missed? Anything you care to share with your config that may be useful?

Thanks...

Shannon

Re: Frequent Recovery Point - Passive Node Issues

Shannon,

That is exactly what is occurring.

Thanks for looking into this...

Re: Frequent Recovery Point - Passive Node Issues

Hi Todd...

Can you add this following switch to the end of your FRP backup string -

-BackupCopyRemoteCCRNode $False

The BackupCopyRemoteCCRNode is $True by default. Setting it to $False should tell SME to only perform operations on the node where it's running (in your case, the passive node).

Let me know if that fixes the issue.

Thanks...

Shannon

Re: Frequent Recovery Point - Passive Node Issues

That worked like a charm Shannon!

Thanks a ton...I have read a few of your whitepaper on Best Practices for SME. Is there currently a Best Practice Guide for SME 5 with CCR?

It is funny that there is no option in the GUI for this as there is in the normal backup wizard?

Re: Frequent Recovery Point - Passive Node Issues

No problem at all Todd...I'm happy to help.

There's no specific BP guide for SME 5.0 with CCR. Is there something in particular you're looking for? If you have some details on what you'd like to see covered, I can definitely add something to the SME 5.0 BP Guide (in process right now).

And there is definitely no option for this switch in the FRP UI. I'm actually going to file a bug on that and see if we can get it targeted to a future release of SME. Even if it was in an "Advanced" menu or something similar...that would be handy. Till that happens though, you just need to manually add the switch to the end of the FRP backup string once you create the job through the UI.

Thanks...

Shannon

Re: Frequent Recovery Point - Passive Node Issues

I have a similar problem except we are running Exchange 2003 no clustering and

the copied logs from a Frequent Recovery Point are not being purged. We take SNAPS every 4 hrs where we truncate the logs.

Frequent Recovery Point Backup

"C:\Program Files\NetApp\SnapManager for Exchange\SMEJobLauncher.exe" new-backup -Server 'HNATLD1SVREXG04' -NoTruncateLogs $False -StorageGroup 'HNATLD1SVREXG04SG1','HNATLD1SVREXG04SG4','HNATLD1SVREXG04SG2','HNATLD1SVREXG04SG3' -RecoveryPoint -BackupCopyRemoteCCRNode $False

Full Backup

"C:\Program Files\NetApp\SnapManager for Exchange\SMEJobLauncher.exe" new-backup -Server 'HNATLD1SVREXG04' -GenericNaming  -ManagementGroup 'Daily' -NoTruncateLogs $False -RetainDays 2 -StorageGroup 'HNATLD1SVREXG04SG1','HNATLD1SVREXG04SG4','HNATLD1SVREXG04SG2','HNATLD1SVREXG04SG3' -UseMountPoint  -MountPointDir 'C:\Program Files\NetApp\SnapManager for Exchange\SnapMgrMountPoint' -BackupCopyRemoteCCRNode $False