Subscribe
Accepted Solution

HANA Plugin

[ Edited ]

Hi Community,

 

I've a problem by configuring the HANA plugin in SC 4.1.1. I've setup the plugin and I'm able to quiese the HANA database. When the database is quiesed a HANA Snapshot is created and shown in the backup catalog as a snapshot like backup.  When I unquiese the database the HANA snapshot is deleted.

When I try to perform a backup via SC the database is quiesed, the HANA snapshot is created (listed in Backup catalog), the storage snapshot is created and the database is unquiesed.

Unfortunately the backup entry in the backup catalog disappears when the backup is finished (successfully).

Did I miss something?

 

Thank you.

Best Regards,

Andreas

Re: HANA Plugin

Hi,

 

it seams the HANA plugin is not confirming the storage snapshot in the backup catalog. 

Therefore after deleting the HANA snapshot via "BACKUP DATA DROP SNAPSHOT" the snapshot is gone but also the information in the backup catalog.

Did I miss something?

 

Best Regards,

Andreas

Re: HANA Plugin

Anyone?

Thanks

BR,

Andreas

 

Re: HANA Plugin

Hi Andreas,

 

Could you please share SnapCreator Agent and Server logs for study?

 

Regards,

Saravana

Re: HANA Plugin

Hi Saravana,

 

thanks for your reply.

Of course I can... is it possible to sent the logs directly to you via email?

 

Best Regards,

Andreas

 

Re: HANA Plugin

Hi Andreas,

HANA plug-in will also do cleanup of snapshots from the HANA Backup Catalog as per the Snapshot retention policy set in the Snap Creator config.

If you retain daily 1 snapshot, old backup catalog entries will be deleted when the snapshot is cleaned up as part of retention.

 

The exisiting snapshots on NetApp storage should in any case exist in the backup catalog if they were created through the HANA plug-in.

 

Saravana will help you further with this issue. Once he receives the logs and config he will be able to debug the issue for you.

Thanks,

Kapil

Re: HANA Plugin

 Hi Kapil,

 

thanks for your reply.

I've a retention of five snapshots and I get the problem even if there is no snapshot on the volume. 

 

The situation is: 

- HANA snapshot is created, checked via select * from m_snapshots

- I can see an entry in the backup catalog

- Storage Snapshot is created

- HANA snaphot is deleted,  but then the entry in the backup catalog dissapears

- Storage Snapshot is available 

 

Thanks,

BR,

Andreas

Re: HANA Plugin

Hi Andreas,

 

Please send config and log files to my email id saravana.s@netapp.com

 

Regards,

Saravana

Re: HANA Plugin

Hi Andreas,

What is your version of HANA DB?

Kapil

Re: HANA Plugin

Hi Kapil,

 

1.00.097.00 but I've the same problem with another system which is on level 1.00.091.00.

 

I've sent the config and logs to Saravana.

 

Thanks!

Best Regads,

Andreas