Subscribe

HTTP ERROR: 503 - SERVICE_UNAVAILABLE

[ Edited ]

Hello,

I have troubles setting up the SnapCreator Framework 3.3.0 on Windows Server 2008 R2 Server. I followed the Instructions from the “NetApp Snap Creator Framework 3.3.0 Installation and Administration Guide”:

1.      Extracted the files

2.      Ran snapcreator--profile setup from the scserver3.3.0 directory

3.      Started the GUI as followed:

"C:\Program Files\Java\jre6\bin\java.exe" -jar "C:\Program Files\NetApp\SnapCreatorFramework\scServer3.3.0\gui\snapcreator.jar"

Starting Derby Server

Testing if the Derby Server is up and running!

Derby Server now running

Got an embedded connection.

Testing embedded connection by executing a sample query

number of rows in sys.systables = 38

While my app is busy with embedded work, ij might connect like this:

        $ java -Dij.user=me -Dij.password=pw -Dij.protocol=jdbc:derby://localhos

t:1527/ org.apache.derby.tools.ij

        ij> connect 'snapcreator';

log4j:WARN No appenders could be found for logger (org.mortbay.log).

log4j:WARN Please initialize the log4j system properly.

Starting Jetty Server

Jetty Server Started on port: 8080

4.      Problem: Opening the URL http://localhost:8080 results in the error

HTTP ERROR: 503

Problem accessing /. Reason:

    SERVICE_UNAVAILABLE

--------------------------------------------------------------------------------

Powered by Jetty:// 

I didn't expected to get the first troubles in this early setup process. Anyone with an idea?

Kind Regards

Frank Friebe

Re: HTTP ERROR: 503 - SERVICE_UNAVAILABLE

Hi Frank,

Make sure that no windows fire wall is turned on, you can test this by opening another command prompt and doing following command "telnet localhost 8080" you should get a connection, if not then this is an OS issue with firewall.

Also make sure you have java 1.6 or higher, run following command to verify "C:\Program Files\Java\jre6\bin\java.exe -version", it looks like you do since folder says jre6 but just to be 100% sure.

Regards,

Keith

Re: HTTP ERROR: 503 - SERVICE_UNAVAILABLE

Hi Keith,

Thanks for the fast answer.

The firewall is disabled via gpo, java is installed in version 1.6.0_24 (only one java version running)

Thanks

Frank

Re: HTTP ERROR: 503 - SERVICE_UNAVAILABLE

What does "telnet localhost 8080" do?

Keith

Re: HTTP ERROR: 503 - SERVICE_UNAVAILABLE

Hi Frank,

Please review the proxy server configuration inside iExplorer.

It's possible that you need to introduce the ip local server, how to exceptions.

Regards,

Re: HTTP ERROR: 503 - SERVICE_UNAVAILABLE

Hi,

telnet connects to port 8080 - showing an empty telnet screen after the connection is set up

Frank

Re: HTTP ERROR: 503 - SERVICE_UNAVAILABLE

Hi jocana,

Good idea but no proxy configured. Also if i add the http://localhost to the local intranet sites there is no change. Still Service Unavailable

Frank

Re: HTTP ERROR: 503 - SERVICE_UNAVAILABLE

Ok this is very strange, we have never seen this issue. Assuming this configuration is supported in IMT I would recommend opening a support case. In addition it would be helpful to see the logs under gui/logs and configs under /gui/etc. Maybe you could collect those for us and post them?

On the plus side, SC is not dependent on the GUI so you can still do everything from CLI by editing the config file by hand, maybe this is a good option? Other option is try installing on a different system, using the agent it really doesn't matter where the SC Server resides, windows or unix.

Regards,

Keith

Re: HTTP ERROR: 503 - SERVICE_UNAVAILABLE

Hi Frank,

I was able to reproduce this exact erron on a Linux box and I believe I know the issue. When starting the gui you must be in the gui directory where the snapcreator.jar is located.

Please try following:

cd /scServer3.3.0/gui

java -jar snapcreator.jar

Let me know if this works?

Regards,

Keith

Re: HTTP ERROR: 503 - SERVICE_UNAVAILABLE

Hello.

Mr. Friebe opened a ticket at NGS for further troubleshooting.

We checked the processes and their opened ports but everything is running fine.

Starting  the java after changing into the gui directory C:\Program  Files\NetApp\SnapCreatorFramework\scServer3.3.0\gui solved the issue  (like assumed from Keith Tenzer - thanky you at that point)!

The NGS ticket is marked as solved, so this thread can also be marked as answered.

Best Regards,

Mike

Technical Support Engineer

EMEA Technical Support Center