Subscribe

LIF problem with ndmp vserver-scope and Avamar

Hi,

We try to backup a MetroCluster CDOT single node 8.3.2 with Avamar in vserver scope.

We want's to use a dedicated network for the ndmp backup. The Accelerated node avamar is in this NetWork.

 

But when we are in vserver-scope, and we want to backup a vserver volume, we selected it and when the backup start, it fails because he use an another LIF wich can comunicate with avamar !!!

We tried to use a dedicated InterCluster LIF, a dedidicated Cluster-mgmt LIF and a dedicated data-lif : Same problem. Avamar wants to use an InterCluster LIF used by the MetroCluster, or the Cluster mgmt LIF of the admin network, or an SVM LIF admin but neither the dedicated backup LIF.

 

The connection with avamar is correct, we can browse volumes, but when we start, another LIF is used.

 

On the NetApp CDOT we can only select the prefered-role on ndmp but how can we select the prefered LIF ?

And on Avamar side we didn't have a prefered ndmp interface...

 

So how can we do it ?

 

Laurent

Re: LIF problem with ndmp vserver-scope and Avamar

Hi Laurent,

 

You can modify the preferred NDMP LIF role using:

 

cluster1::> vserver services ndmp modify -vserver vserver1 -preferred-interface-role {cluster|data|node-mgmt|intercluster|cluster-mgmt}, ... ]  Preferred Interface Role

Also assume you've checked your configuration as per the documentation below:

 

https://library.netapp.com/ecmdocs/ECMP12366513/html/GUID-B9E37D91-05A7-4AC9-BDDD-24AB7A7DED50.html

https://library.netapp.com/ecmdocs/ECMP12366513/html/GUID-932EC20E-B0CB-4626-B57F-8A26AEAC90CA.html

 

/Matt

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: LIF problem with ndmp vserver-scope and Avamar

I do it, but in my case, all the LIF have a data role : (admin, production CIFS and ndmp).

I thinks that NetApp sends the three LIF with the role data to avamar, and avamar use one by alphabetic order....

Re: LIF problem with ndmp vserver-scope and Avamar

Were you able to find a solution?  We are having the same issue.  It seems to rotate between the available LIFs even when only one LIF should be used