Subscribe

Latest Java version for smogui 3.0.x

[ Edited ]

Hello

What version of Java is required for the latest smogui 3.0.x?  smogui sometimes failing with nullpointerexception.

Thank you in advance for your help.

-Mitchell

Re: Latest Java version for smogui 3.0.x

Hi Mitchel,

You have to use JRE 1.5. Newer Versions won't work

Ciao

Michael

Mit freundlichen Grüßen / best regards

Michael Schlosser

Enterprise Infrastructure Architect

NetApp Deutschland GmbH

Gutenbergstraße 10

63263 Neu-Isenburg

+49 151 120 55 714

NetApp Deutschland GmbH, Bretonischer Ring 6, 85630 Grasbrunn,Handelsregister: AG München HRB113907, Geschäftsführer: Manfred Reitner (Vorsitzender), Dr. Dierk Schindler, Volker Weisshaar, Fritz Meijaar

Re: Latest Java version for smogui 3.0.x

We currently support 1.5.  There are known issues with 1.6 versions and that will be addressed in a future release.

An NPE isn't necessarily an issue with the version of Java you are running.  So if you are on 1.5, then you need to look at running a smo dump of some kind depending on what operation is failing.  May need a snapdrive.dc depending on the error.

Would suggest you open a support case.

-Mark

Re: Latest Java version for smogui 3.0.x

I will try it and reply, if it did not work. Thank you.

-Mitchell

Re: Latest Java version for smogui 3.0.x

Agreed. I will install 1.5 and review smogui for performance and if it still did not go any faster/smoother, I will send out the logs for your review. Thank you.

-Mitchell

Re: Latest Java version for smogui 3.0.x

Hi Mark,

Same problem here, in corporate enviorniment you can't control what everybody has on his laptop (JRE5 vs JRE6), according to the http://en.wikipedia.org/wiki/Java_version_history JRE 6 was released in December 2006... but still snapmanagers don't work with JRE6 ?  What is time frame for releasing fixing SMO/SMSAP that are going to support JRE6?

Thanks, Jakub.

Re: Latest Java version for smogui 3.0.x

I'm on leave on 19th and 20th July. Please contact my manager Senthil

for anything urgent

Thanks,

Vrishali

Re: Latest Java version for smogui 3.0.x

It's a currency issue for SMO/SMSAP Engineering and I know it is in the process of being resolved.

However, I have no info for you regarding a release schedule.

Will get PM to comment when there is a firm schedule.

-Mark

Re: Latest Java version for smogui 3.0.x

That figures! ☺ How about an employee 401K investment program towards SMO/SMSAP? ☺ It’s a great tool, if given the chance to be completed.

Re: Latest Java version for smogui 3.0.x

SMO 3.1, anticipated for delivery late summer, is going to support JRE 1.6.  We have added JRE to our currency matrix, and will be working to improve our support in that area.