Subscribe

Oracle cloning question

[ Edited ]

Hi all,

I've just started testing the oracle plug-in in my lab and built a working backup/snapvault config. When I try to clone the database from this configuration, the cloning operation fails because the wrong (nonexistent) snapshot is selected for the clone operation:

The (to my understanding) relevant parts of the config:

########################

### Required Options ###

########################

CONFIG_TYPE=STANDARD

SNAME=sc_ora_win

SNAP_TIMESTAMP_ONLY=N

VOLUMES=dedusngs01:jt_orawin_rdm_arch,jt_orawin_rdm_data

NTAP_SNAPSHOT_RETENTIONS=hourly:5

NTAP_USERS=...

NTAP_PWD_PROTECTION=Y

TRANSPORT=HTTP

PORT=80

LOG_NUM=10

SC_TMP_DIR=

########################

### Snapshot Options ###

########################

NTAP_SNAPSHOT_RETENTION_AGE=1

SNAPDRIVE=N

SNAPDRIVE_DISCOVERY=N

NTAP_SNAPSHOT_DISABLE=N

NTAP_SNAPSHOT_NODELETE=N

NTAP_CONSISTENCY_GROUP_SNAPSHOT=Y

NTAP_CONSISTENCY_GROUP_TIMEOUT=relaxed

NTAP_CONSISTENCY_GROUP_WAFL_SYNC=N

NTAP_SNAPSHOT_DELETE_BY_AGE_ONLY=N

NTAP_SNAPSHOT_DEPENDENCY_IGNORE=N

NTAP_SNAPSHOT_RESTORE_AUTO_DETECT=Y

#######################

### Cloning Options ###

#######################

NTAP_VOL_CLONE_RESERVE=none

NTAP_LUN_CLONE_RESERVATION=false

NTAP_CLONE_IGROUP_MAP=

NTAP_CLONE_FOR_BACKUP=N

NTAP_CLONE_SECONDARY=N

NTAP_CLONE_SECONDARY_VOLUMES=

NTAP_NUM_VOL_CLONES=1

NTAP_NFS_EXPORT_HOST=

NTAP_NFS_EXPORT_ACCESS=

NTAP_NFS_EXPORT_PERSISTENT=

The result:

./snapcreator --profile Oracle_Backups --config advJONTORACLE1 --action clone_lun --policy hourly --verbose

... no errors up to this point ...

########## Creating Lun Clone(s) for source dedusngs01 ##########

[Fri Dec 23 12:01:35 2011] INFO: Creating Lun Clone /vol/jt_orawin_rdm_arch/arch/arch1.lun_CLONE from snapshot sv_hourly.0 on dedusngs01:jt_orawin_rdm_arch

[Fri Dec 23 12:01:35 2011] DEBUG: ZAPI REQUEST

<lun-create-clone>

    <parent-lun-path>/vol/jt_orawin_rdm_arch/arch/arch1.lun</parent-lun-path>

    <parent-snap>sv_hourly.0</parent-snap>

    <path>/vol/jt_orawin_rdm_arch/arch/arch1.lun_CLONE</path>

    <space-reservation-enabled>false</space-reservation-enabled>

</lun-create-clone>

[Fri Dec 23 12:01:35 2011] DEBUG: ZAPI RESULT

<results status="failed" errno="9043" reason="No such snapshot"></results>

[Fri Dec 23 12:01:35 2011] OUTPUT: No such snapshot

[Fri Dec 23 12:01:35 2011] ERROR: [scf-00013] NetApp Lun Clone Create of /vol/jt_orawin_rdm_arch/arch/arch1.lun_CLONE from sv_hourly.0 on dedusngs01:jt_orawin_rdm_arch failed! Exiting

The question:

Where is SC getting the idea that the base Snapshot is named "sv_hourly.0"? Do I have a misconfigured log file or is this name hard-coded somewhere?

Any ideas?

Thanks,

--Jon

Re: Oracle cloning question

Hi Jon,

What is this option set to in config NTAP_SNAPVAULT_SNAPSHOT

The only way SC could be looking for a sv_hourly.0 is if NTAP_SNAPVAULT_SNAPSHOT=Y

I just tested this with NTAP_SNAPVAULT_SNAPSHOT=N

########## Creating Lun Clone(s) for source cuba2 ##########

[Fri Dec 23 19:08:40 2011] INFO: Creating Lun Clone /vol/sc_qa_pri1/qtree1/lun1.lun_CLONE from snapshot db2prd-daily_20111223190729 on cuba2:sc_qa_pri1

[Fri Dec 23 19:08:40 2011] INFO: Lun Clone Create of /vol/sc_qa_pri1/qtree1/lun1.lun_CLONE from db2prd-daily_20111223190729 on cuba2:sc_qa_pri1 Created Successfully

[Fri Dec 23 19:08:40 2011] INFO: Creating Lun Clone /vol/sc_qa_pri1/restore1/test1.lun_CLONE from snapshot db2prd-daily_20111223190729 on cuba2:sc_qa_pri1

[Fri Dec 23 19:08:40 2011] INFO: Lun Clone Create of /vol/sc_qa_pri1/restore1/test1.lun_CLONE from db2prd-daily_20111223190729 on cuba2:sc_qa_pri1 Created Successfully

[Fri Dec 23 19:08:40 2011] INFO: Creating Lun Clone /vol/sc_qa_pri1/restore2/test1.lun_CLONE from snapshot db2prd-daily_20111223190729 on cuba2:sc_qa_pri1

[Fri Dec 23 19:08:40 2011] INFO: Lun Clone Create of /vol/sc_qa_pri1/restore2/test1.lun_CLONE from db2prd-daily_20111223190729 on cuba2:sc_qa_pri1 Created Successfully

[Fri Dec 23 19:08:40 2011] INFO: Creating Lun Clone /vol/sc_qa_pri1/test1.lun_CLONE from snapshot db2prd-daily_20111223190729 on cuba2:sc_qa_pri1

[Fri Dec 23 19:08:40 2011] INFO: Lun Clone Create of /vol/sc_qa_pri1/test1.lun_CLONE from db2prd-daily_20111223190729 on cuba2:sc_qa_pri1 Created Successfully

Worked

I also tested this with NTAP_SNAPVAULT_SNAPSHOT=Y

########## Creating Lun Clone(s) for source cuba2 ##########

[Fri Dec 23 19:10:04 2011] INFO: Creating Lun Clone /vol/sc_qa_pri1/qtree1/lun1.lun_CLONE from snapshot sv_daily.0 on cuba2:sc_qa_pri1

[Fri Dec 23 19:10:04 2011] INFO: Lun Clone Create of /vol/sc_qa_pri1/qtree1/lun1.lun_CLONE from sv_daily.0 on cuba2:sc_qa_pri1 Created Successfully

[Fri Dec 23 19:10:04 2011] INFO: Creating Lun Clone /vol/sc_qa_pri1/restore1/test1.lun_CLONE from snapshot sv_daily.0 on cuba2:sc_qa_pri1

[Fri Dec 23 19:10:05 2011] INFO: Lun Clone Create of /vol/sc_qa_pri1/restore1/test1.lun_CLONE from sv_daily.0 on cuba2:sc_qa_pri1 Created Successfully

[Fri Dec 23 19:10:05 2011] INFO: Creating Lun Clone /vol/sc_qa_pri1/restore2/test1.lun_CLONE from snapshot sv_daily.0 on cuba2:sc_qa_pri1

[Fri Dec 23 19:10:05 2011] INFO: Lun Clone Create of /vol/sc_qa_pri1/restore2/test1.lun_CLONE from sv_daily.0 on cuba2:sc_qa_pri1 Created Successfully

[Fri Dec 23 19:10:05 2011] INFO: Creating Lun Clone /vol/sc_qa_pri1/test1.lun_CLONE from snapshot sv_daily.0 on cuba2:sc_qa_pri1

[Fri Dec 23 19:10:05 2011] INFO: Lun Clone Create of /vol/sc_qa_pri1/test1.lun_CLONE from sv_daily.0 on cuba2:sc_qa_pri1 Created Successfully

Worked

This was with SC 3.5 code, what version do you have?

Also can you send the IP address for dedusngs01 and the entire config file? I can test it from here to see what is going on.

Regards,

Keith