Subscribe

Orphaned Exchange Snapshots?

[ Edited ]

Have a look at the attached screenshot of my FilerView from the Volumes->Snapshots->Manage page. I've noticed these for a while and have never dealt with it. There seems to be many "orphaned" snapshots that are stuck and haven't been deleted by SnapManager for Exchange. Notice...

1) Several items are listed as a status of "busy, LUNs - Busy".

2) All these "busy" items as well as others are way out of date and should long ago have been deleted. In general, it is keeping one snapshot from each month (seems to be every 2nd Thursday of the month) as well as several that are named with what looks like some sort of GUID.

3) I checked the SnapManager logs where it is to delete old snapshots. All these "2nd Thursday" entries give an error of "SnapDrive is unable to delete a snapshot (blah blah) because this snapshot is busy."

Why aren't these being deleted? What are they "busy"? Why are there all those old February "GUID"-named entries? Anybody have any thoughts or explanations?

Re: Orphaned Exchange Snapshots?

Do you have any Flexclones connected to the snapshot or NDMP backups running?

Re: Orphaned Exchange Snapshots?

No (not even sure what a Flexclone is) and no.

Re: Orphaned Exchange Snapshots?

Hi, Robert. There's a long explanation why you can end up with busy LUN conditions with your snapshots. I'll try to be brief. First, the problem you are having is briefly described in the SnapManager® StoreVault Edition 4.0S1 for Microsoft® Exchange Installation and Administration Guide:

http://now.netapp.com/NOW/knowledge/docs/s_family/software/html/software/iag_sme/ssmgmt4.htm#1201315

It's occurring because you have a LUN mounted to a Windows server and a snapshot of the volume holding that LUN is taken while that LUN is mounted. This can happen for a variety of reasons (not all are listed here):

1) You are performing an Exchange verification which mounts the LUN (and creates a LUN clone to do that), and for some reason a snapshot takes place while you are doing that;

2) You are using other tools like SMBR to look at a mounted LUN from an older backup, and that LUN is left mounted while the SMBR operations take place;

3) You have other LUN mount operations that take place through your backup application that are still running by the time the next SME backup happens.

When the snapshot is taken, the LUN clone (which ends with the name .rws if created via SnapDrive) is "trapped" in the snapshot. The only way to get rid of it is to delete the snapshots that have the trapped LUN clone.

There is a KB article that describes how to eliminate the snapshots, which I'll include below, but I would strongly recommend reaching out to your support provider (depending on your platform and support contract -- I believe your support number is 1-877-278-7858 but you should confirm) for help in clearing the situation if you are unsure of the steps or don't know which snapshots to delete. The KB article is:

https://now.netapp.com/Knowledgebase/solutionarea.asp?id=kb16908

Thanks,

--Matt