Subscribe
Accepted Solution

PRE_CLONE_CREATE_CMD in mount action

[ Edited ]

Hello,

 

I would like to ask a question, if it's possible to use some king of PRE_CLONE_CREATE_CMD in Mount action. This command is lauched only in cloneLun or cloneVol action, not in Mount action.

 

What is my problem?

Customer creates clones from existing snapshots with Mount action. It works fine, but sometimes it would be very helpful if you can stop the action (in case of some errror) and exit with an error code/message forwarded to DFM before creating snapshot. In Umount action it's ok - PRE_UMOUNT_CMDs run before physical clone destroy. In Mount action, PRE_MOUNT_CMDs are running after the clone is created. It means that clone is created every time if Mount action is started and you have now change to break the clone creation process. And such "zombie" clones stay on the controller and cause problems in snapshot retentoin - snapshots are busy and can't be deleted.

 

Thanks for any help.

 

BR,

Rostislav

 

 

Re: PRE_CLONE_CREATE_CMD in mount action

Hi,

 

It is possible to customize the mount workflow. 

SnapCreator installation contains workflow xml files which controls the workflows/actions. 

 

In your case, in the mount.xml, before the "VolCloneCreate" task, add the following task.

 

<step task="preCloneCreateCMD" configs="#APP_VM" abortStep="agentFinalizeWorkflow"

if="#APP_VM.application.definedMount == false">

</step>

 

In your config file, define the neccesary cmd in 

PRE_CLONE_CREATE_CMD param.

 

Thanks,

Amar

Re: PRE_CLONE_CREATE_CMD in mount action

Thanks a lot for the advice!

 

I have changed scServer4.1.2/engine/etc/workflow/mount.xml, restarted scServer and it works! Smiley Happy