Subscribe

Panic: '/usr/lib64/perl5/CORE/libperl.so' is not an ActivePerl 5.16 library

Hello,

 

 

Trying to install the Snap Creator Framework 4.3.0 (NetApp_Snap_Creator_Framework4.3.0-Linux64.tar.gz) on an updated CentOS 6.7 x86_64 VM and I'm getting this error:

# ./snapcreator --version
Panic: '/usr/lib64/perl5/CORE/libperl.so' is not an ActivePerl 5.16 library

 

I see the ActivePerl 5.16 library has been extracted to /tmp

-rw-r--r--. 1 root root 1695429 Mar 16 18:51 /tmp/pdk-root/6151bd27d058318dfe87a1aefbb0deda/libperl.so

 

I'm running the install as the root user and there's plenty of space on /tmp

 

Filesystem            Size  Used Avail Use% Mounted on

/dev/mapper/vg_os-lv_tmp
                      2.9G  6.5M  2.8G   1% /tmp

 

Ok, I'm going to now answer my own question.  Because of our security policies /tmp was mounted with some extra paramemters which casued the issue. 

     /dev/mapper/vg_os-lv_tmp    /tmp    ext4    defaults,nodev,nosuid,noexec    1 2

 

# ./snapcreator --version
ERROR: [scf-00130] End User License Agreement was not accepted, please run "./snapcreator --setup" to accept the End User License Agreement

 

Hopefully this will help someone else who runs into the same issue.  Also remember to make sure SELinux is either permissive or disabled.

 

 

Thanks,

Jim

 

Re: Panic: '/usr/lib64/perl5/CORE/libperl.so' is not an ActivePerl 5.16 library

Thanks for sharing this information.

 

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.