Subscribe

Periodiac "orphaned" clones after W2K8 System State Backup

When using Windows 2008 with SnapDrive for Windows 6.1 we are seeing an anomaly from time to
time. When the System State Backup job runs out of the task scheduler, VSS creates snapshots of the LUNs
(Fibre Channel) connected to the host (E:, F:, etc). Normally these are there until the job completes and
then they go back away. From time to time we see where the clones do not go away, yet the job seems
to finish ok. What we are then left with is an "orphaned clone" which will sit there and lock blocks until manually
removed. I've not been able to find a way yet to reproduce this on demand and the manual check and remove is
getting old. Apparently the process uses VSS to create the snap/clone and then something is not releasing
every time. They have some hosts where this seems to happen frequently and others where we have
never seen this - all the same Windows 2008, but running various applications.
Is there a good way to monitor or trouble shoot this?
Here is the mainline running in the batch scheduler:
%SystemRoot%\system32\WBADMIN START SYSTEMSTATEBACKUP -backuptargetSmiley Very Happy: -quiet

Re: Periodiac "orphaned" clones after W2K8 System State Backup

You cannot use wbadmin on 2008 if there are hardware vss providers installed on the system.

havea look at the following MS KB http://support.microsoft.com/kb/955687

Re: Periodiac "orphaned" clones after W2K8 System State Backup

Great note. Thanks for that feedback. What I found was that the condition was only a problem

on volumes that were almost out of space. If I made sure there was adequate freespace in the

volume where the LUNs are (say 5% free), then we never saw this condition. Seems to work

if there is space, but good to know there are other issues which need to be addressed.