Subscribe

Problem with Operations Manager events

[ Edited ]

Hi!

I just installed Snapcreator 3.4.0 on a Windows host for the first time.

Did it on Linux hosts before where it worked just fine.

IIt works well on the Windows host to until i wanted to get events to the OM server.

I entered the following in the config file:

###################################

### Operations Manager Settings ###

###################################

OM_HOST=segotn878

OM_USER=sapscadm

OM_PWD=sapdb201

OM_PORT=8080

OM_EVENT_GENERATE=Y

I also tested to login to the DFM server on that windows host with Internet Explorer and it worked just fine.

This is the result at the end of an execution:

########## NetApp Snap Creator Framework finished successfully ##########

[Tue Nov 22 11:37:27 2011] INFO: INFO: NetApp Snap Creator Framework finished successfully ( Action: snap )

[Tue Nov 22 11:37:27 2011] ERROR: validation of target segotn878 failed [

syntax error at line 1, column 49, byte 49:

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">

================================================^

<html><head>

<title>404 Not Found</title>

at /<C:\Program Files\NetApp\NetApp_Snap_Creator_Framework\scServer3.4.0\snapcreator.exe>XML/Parser.pm line 187

]

[Tue Nov 22 11:37:27 2011] ERROR:

syntax error at line 1, column 49, byte 49:

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">

================================================^

<html><head>

<title>404 Not Found</title>

at /<C:\Program Files\NetApp\NetApp_Snap_Creator_Framework\scServer3.4.0\snapcreator.exe>XML/Parser.pm line 187

Any suggestions to what i am missing here?

Are there some additional requirements for a Windows host?

Regards Magnus

Re: Problem with Operations Manager events

I solved it.

It was the wrong port. 8088 worked.

But now the question arised about using https communication to OM server.

Is that possible?

I found no option for protocol.

Regards Magnus

Re: Problem with Operations Manager events

Certainly you can use HTTPS. Set OM_PORT=8488 and ensure that port is open from scServer to DFM server

Regards,

Keith