Subscribe

Problem with SC 4.1P1 GUI and NTAP_DFM_DATA_SET

[ Edited ]

We have just installed sc4.1P1 and are migrating our old configuration from our old SC3.5 environment to 4.1P1 (creating new configuration files from the GUI).

It seems that the GUI is not parsing the NTAP_DFM_DATA_SET correctly and save it in a "strange" format.

When creating a new Configuration that have 5 volumes in it SC4.1P1 create a new Dataset in DFM and then save the configuration with this NTAP_DFM_DATA_SET line:

NTAP_DFM_DATA_SET=itromfs22:snapcreator_GRC/GRC_Arch;itromfs22:snapcreator_GRC/GRC_Data;itromfs22:snapcreator_GRC/GRC_Exe;itromfs22:snapcreator_GRC/GRC_Log;itromfs22:snapcreator_GRC/GRC_Report

The line seems formally correct but at least the GUI will not display it and after going on the Oncommand/DFM tab it start to malfunction (you change to other config tab but it will not display anything, you cannot change any config parameter).

In the Oncommand/DFM TAB on the Dataset part of the window it will not display any dataset. it Seems like it's trying to elaborate something but is looping on something.

To make it work again I've to manually change the line to this format (that was the one I was expecting to see into the config file saved):

NTAP_DFM_DATA_SET=itromfs22:snapcreator_GRC/GRC_Arch,GRC_Data,GRC_Exe,GRC_Log,GRC_Report

I've also Another problem with the same configuation parameter. For various reason I have 2 different configuration to do oracle backup.

Normally in the full backup I do a oracle online consistent backup with the plugin and then a mirror of all volumes (data and archive). I do the full backup 1 time a day. Every hour I do an archive only backup/mirror (to copy them to DR site) and to do this I have 2 configuration file:

1) to do a full snapshot/online backup - mirror that has all volumes

2) for the archive log only backup I have a configuration file with only the archivelog volume.

For this I have 2 DFM Dataset configured, One with Data/onlinelog/oraclehome and one with Archivedlogs.

Putting this line of configuration will not work correctly on the gui (I'm expecting to see 2 dataset but I only see one):

NTAP_DFM_DATA_SET=itromfs22:snapcreator_GRC/GRC_Data,GRC_Exe,GRC_Log,GRC_Report;itromfs22:snapcreator_GRC_arch/GRC_Arch

This is what I see (2 dataset 1 storage, the second dataset is not there):

If I change the second dataset storage name to itromfs23 (another storage) it works. So it seems there's something wrong with dataset parsing:

So it seems there's something strange in the dataset parameters NTAP_DFM_DATA_SET parsing and saving or I'm doing something wrong?

Thanks

Francesco

Re: Problem with SC 4.1P1 GUI and NTAP_DFM_DATA_SET

Siva – This one is all you

Leaving for vacation now.

Have a nice weekend.

John

Re: Problem with SC 4.1P1 GUI and NTAP_DFM_DATA_SET

filed product defect# 898801, for the incorrect syntax generated by SC when creating a config with a dataset.

Domenico.

Re: Problem with SC 4.1P1 GUI and NTAP_DFM_DATA_SET

today we opened also a defect burt (899136) for the cosmetic issue with the GUI not showing correctly two datasets within one sc config, if the volumes are on the same storage system.

We can close this thread now.

Domenico.