Subscribe

Problem with SnapDrive after Light Problems

Hi all.

Yesterday, all our CPD go down because of a Light Problem in the building. All servers, and the NetApp, were offline for about 10 mins or so.

After that, we made a programmed boot of all the elements, and basically, all is working fine, EXCEPT for one server.

Properties:

W2k with all the updates

SnapDrive 4.2.1

NetApp:

Fas3020

Version: 7.2.6.1P9

The problem is:

We tryed to restart the server, in the event log, it shows this error.

Failed to enumerate virtual disk.
Device path: '\\?\scsi#disk&ven_netapp&prod_lun&rev_0.2#7&76e98cc&1&000#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}'
Lun path: '/vol/vol_repositorio_pixel/repositorio_pixel.lun'
SCSI address: (3,0,0,0)
Error code: 0xc0040375
Error description: 'LUN is not recognized by Windows. Possible reasons: this disk is not formatted, or this disk is under delete/disconnect/restore operation. Filer 'BMB-2', path '/vol/vol_repositorio_pixel/repositorio_pixel.lun', s/n 'C4n9OZSCoVPs'.

Then, We unmap the resource in the filer, and then we tryed to connect to the existing lun.

We had problems, cos the time was not syncronized, We sincronized it, and managed to conect to the lun.

The map shows in the Netapp, but after 600 s, the event log shows an timeout error.

this error.

Failed to connect to virtual disk. Failure in connecting to the virtual disk.
Virtual Disk Name = repositorio_pixel.lun
Virtual Disk Path = /vol/vol_repositorio_pixel/
Protocol Type = LUN
Filer Name = 172.16.1.105
UNCPath = \\172.16.1.105\repo_pixel$\repositorio_pixel.lun
Requested Mount Point = R
Assigned Mount Point =
Error code : A timeout of 600 secs elapsed while waiting for volume arrival notification from the operating system.

The Netapp shows the map, so it connects, but then... timeout (or error)

Initiator Group LUN ID Unmap
viaRPC.50:01:43:80:03:ae:ac:72.VALPIX01

I have tryed to restart the server, and reconect, and it shows that error after waiting. I'm lost...

any advice ? ¿Any way to get more info that only the event?

Re: Problem with SnapDrive after Light Problems

Loioking at the San Sufrfer FC HBA Manager, i see in AppEvents a number of errors.

Those:

Error,Fri Sep 24 11:55:45 CEST 2010,RPC request 57 for Host 172.16.1.203 failed.
Error,Fri Sep 24 11:55:46 CEST 2010,Retrying RPC request 57 for Host 172.16.1.203.
Error,Fri Sep 24 11:55:45 CEST 2010,RPC request 64 for Host 172.16.1.203 failed.
Error,Fri Sep 24 11:55:45 CEST 2010,RPC request 57 for Host 172.16.1.203 failed.
Error,Fri Sep 24 00:00:00 CEST 2010,Retrying RPC request 57 for Host 172.16.1.203.
Error,Fri Sep 24 00:00:00 CEST 2010,RPC request 57 for Host 172.16.1.203 failed.
Error,Fri Sep 24 11:55:45 CEST 2010,RPC request 57 for Host 172.16.1.203 failed.
Error,Fri Sep 24 11:55:45 CEST 2010,Retrying RPC request 57 for Host 172.16.1.203.
Error,Fri Sep 24 11:55:46 CEST 2010,RPC request 57 for Host 172.16.1.203 failed.
Error,Sat Sep 04 00:00:00 CEST 2010,Retrying RPC request 57 for Host 172.16.1.203.
Error,Fri Sep 04 00:00:00 CET 1970,RPC request 57 for Host 172.16.1.203 failed.
Error,Fri Sep 24 11:55:46 CEST 2010,Retrying RPC request 57 for Host 172.16.1.203.
Error,Fri Sep 24 11:55:45 CEST 2010,RPC request 64 for Host 172.16.1.203 failed.
Error,Fri Sep 24 11:55:46 CEST 2010,Retrying RPC request 64 for Host 172.16.1.203.
Error,Fri Sep 24 11:55:46 CEST 2010,RPC request 64 for Host 172.16.1.203 failed.
Error,Fri Sep 24 11:55:46 CEST 2010,Retrying RPC request 64 for Host 172.16.1.203.
Error,Fri Sep 24 11:55:46 CEST 2010,RPC request 57 for Host 172.16.1.203 failed.
Error,Fri Sep 24 11:55:46 CEST 2010,RPC request 64 for Host 172.16.1.203 failed.
Error,Fri Sep 24 11:55:46 CEST 2010,Retrying RPC request 64 for Host 172.16.1.203.
Error,Fri Sep 24 11:55:46 CEST 2010,RPC request 64 for Host 172.16.1.203 failed

I think it's related... but dunno the way... The Domain is UP...

Re: Problem with SnapDrive after Light Problems

I think I have one more point interesting.

In the Administration of the server, in the Disk Management, It shows the OLD Lun unit disk with no letter no disk type.

I'm gonna try to "unplug" it in device manager...

Re: Problem with SnapDrive after Light Problems

Solved.

The SO was detectnign de Old disk, after uninstall it, and reboot, no more event log error.

then I unmap the server, connect it again and voila... it works perfect now.

I put the solution for the future.