Subscribe

Problem with Snapcreator for Domino

[ Edited ]

Hi All,

We installed and configured snapcreator for domino successfully, but after two days the backup falied due to following error:

Database OpenedSmiley Very Happy:\Lotus\Domino\Data\webadmin.ntf

Attempt to backup a database that is currently being backed up.

Error starting Backup.

ERROR_CODE:3748

[Fri Dec 23 16:57:26 2011] INFO: No Errors encountered while opening DBs.

[Fri Dec 23 16:57:26 2011] ERROR: [ltd-00002] Quiescing databases finished with errors

[Fri Dec 23 16:57:26 2011] ERROR: [scf-00053] Application quiesce for plugin domino failed with exit code 1, Exiting!

I searched error code 3748 but didn't find anything. Can anyone tell me what the problem is?

Thanks

Alex

Re: Problem with Snapcreator for Domino

Alex,

The key to this error message is: "Attempt to backup a database that is currently being backed up."

This is generated by the Domino API - something has already put this database into backup mode, so Snap Creator is not able to put it into backup mode again.

My guess is there there is another backup program (TSM, NetBackup, etc)running -or- Snap Creator was run multiple times within a short time period.

Have you had a successful backup with Snap Creator, or has this never worked for you?

Your message said this happened after 2 days, so I hope that means that there were 2 successful backups and then this message appeared (not Snap Creator ran for 2 days).

Hope this helps!

John

Re: Problem with Snapcreator for Domino

Thank John,

Here is the additional information:

We ran scheduled backup successfully for few days, and the retention period is 4 (keep 4 snapshot copy)

the user backup the snapshot copy to other storage by mounting the snapshot use snapdrive on backup server (BackupExec)

Now the user still can't take snapshot, Would anybody know how to solve this problem?

Thanks and Regards,

Alex

Re: Problem with Snapcreator for Domino

Hi John,

Any suggestion for troubleshoot this problem?

Regards,

Alex

Re: Problem with Snapcreator for Domino

Alex,

Sorry for the delay in response.  I am actually on vacation this week, so I check my email infrequently.

I have a couple questions to help narrow things down:

1)  What version of SnapCreator are you using?  SC 3.4, 3.4P1, etc?

2)  Is there any other backup software present on the server?  TSM, NetBackup, etc?

3)  Since receiving this error has a snapshot been attempted again?  What was the result?  (same error, successful, etc)

4)  Did this error occur as part of a scheduled job or as part of a manual snapshot?

5)  If this was part of a manual snapshot were multiple snapshots taken in a short time period?

6)  Since receiving this error message has Domino or the server been restarted? (just wondering)

7)  Does this message occur on just the one database or does it occur on every database?

Thanks!

John

Re: Problem with Snapcreator for Domino

Hi John

See Below comment

1) sc3.4p2

2) no other backup software

3) same error

4) schedule job

5) no, schedule job per 6 hr

6) User didn't mention about that

7) I think just one database I uploaded before

Thanks

Alex

Re: Problem with Snapcreator for Domino

Alex,

Something has that one database locked in backup mode - I doubt that it is Snap Creator because it would cause everything to be locked, not just one database.

You could try running the unquiesce action, but I cannot recall for sure if this options works in SC 3.4 P2 - I know it works with the upcoming 3.5.

If it works with 3.4P2 the unquiesce option will force all databases to end backup mode.  Restarting either Domino or the OS should do the same thing.

If it is just the one database and it is repeatable and you are using 3.4 P2 then the simplest solution might be to edit the config file.

In the APP section of the config file there is a parameter called APP_IGNORE_ERROR

Set this to Y (default is N).  Please note that this needs to be changed directly in the .conf file - this is not currently a parameter that can be changed through the GUI.

APP_IGNORE_ERROR=Y will tell the Domino plug-in to ignore any databases that have errors - this is typically used to deal with database corruption issues, but it should resolve this as well.  The one database will not be placed into backup mode, but the others will and the snapshot should continue.

At the least this will let you know for sure if it is the one database or multiple.  The log file will list all the databases that are having issues.

Please let me know the result.

Thanks,

John

Re: Problem with Snapcreator for Domino

Thank John

my location is HKT 0140 am, and I will go there to try to follow your guide to solve the problem at 1000am.

Will let you know the result

Many Thanks

Alex

Re: Problem with Snapcreator for Domino

Hi John,

We use APP_IGNORE_ERROR=Y to ignore the error, the snapshot created successfully. Thanks

But below error message occur on nsf or ntf file randomly and only one nsf or ntf to be locked

"Attempt to backup a database that is currently being backed up.

Error starting Backup"

Also we found that the following DB is encrypted.

This database has local access protection (encrypted) and you are not authorized to access it

Error opening DBSmiley Very Happy:\Lotus\Domino\Data\iNotes6((xxxxx)V5.ntf

ERROR_CODE:0

[Thu Dec 29 11:06:29 2011] ERROR: [ltd-00010] Errors encountered while opening DBs:

[Thu Dec 29 11:06:29 2011] ERROR: Error opening DBSmiley Very Happy:\Lotus\Domino\Data\iNotes6(xxxxx)V5.ntf

[Thu Dec 29 11:06:29 2011] INFO: Quiescing databases finished successfully

We don't know it is related to the error or not. and we still need to find the solution.

Thank you for your help

Alex

Re: Problem with Snapcreator for Domino

Alex,

This is expected behavior when encountering a locally protected database - the APIs are not authorized to access the database, thus generating the error message.  This is a function of the IBM provided Domino APIs.

I'm not sure I understand what you mean in regards to the "Attempt to backup a database that is currently being backed up" error message.

Are you saying that the database with this error message randomly changes with each snapshot?

I am just looking to clarify.

Due to being on vacation I don't have access to a sample .conf file, so the parameter names below may not be exact...

In the agent section of the .conf file is a parameter named "AGENT_WATCHDOG_ENABLE" or similar name.

What is this set to?  With SC 3.4 P2 I would recommend setting this to N. 

I would also make sure that the AGENT_TIMEOUT is set fairly high - default is 300 seconds, but we usually recommend 900 seconds.

Generally I would say things are working properly from SnapCreator's perspective.

Hopefully the suggestions above will help as well.

There will be a technical report on Snap Creator and the Domino plug-in published in mid-January.

It is going through the publishing process now and the hope is to have it released around the same time as Snap Creator 3.5.

I expect to post about it here on the communities site once it is available.

Thanks,

John