Subscribe

Problems with SMSQL Cloning to remote Host --> 0x80070005 Access is denied

[ Edited ]

Hello @all,

 

i'm a little bit confused about the following error message in my environment.

 

1) 2 VMs (svtidbv057, svtidbv058)

2) Both running W2k8 R2 with SnapDrive 6.2 & SMSQL 5.0

3) Running configuration with Snapshots and Verification are working fine

4) local snapdrive User for SnapDrive and Mngmt with local administrator privileges

5) SnapManager Service running in a Active Directory User with local administrator privileges

 

So ....

We want now to clone a database from VM57 to VM58 by using a recently taken backup.

The task starts and all seems to fine unless ....

 

##########################################################################

[23:41:15.231]  Connecting to SQL Server [svtidbv058] for restore SQL Server version checking...
[23:41:15.245]  Mounting SnapInfo Drive...
[23:41:15.247]  Mounting Snapshot [sqlinfo__svtidbv057__recent] for LUN E of Computer SVTIDBV057
[23:41:15.249]  SnapManager will use directory C:\Program Files\NetApp\SnapManager for SQL Server\SnapMgrMountPoint to mount snapshot sqlinfo__svtidbv057__recent.
[23:41:15.251]  Mount point directory [C:\Program Files\NetApp\SnapManager for SQL Server\SnapMgrMountPoint]
[23:41:15.257]  Snapshot will be mounted on subdirectory [MPDisk001]
[23:41:15.275]  [SnapDrive Error]: Access is denied.

 

(SnapDrive Error Code: 0x80070005)
[23:41:15.277]  Unable to mount the snapinfo directory snapshot
[23:41:15.279] 
[23:41:15.281]  *** SNAPMANAGER MOUNT BY RESTORE (CLONE) JOB ENDED AT: [02-08-2011 23.41.57]

 

[23:41:15.282]  Error Code: 0x80070005
Access is denied.

  ##########################################################################

 

BUT!...

If i try to connect the snapshot via Snapdrive (Connect Disk on remote host svtidbv058) the mounting process starts and ends successfully.

I can access the recently connected disk.

 

There are some events shown on the remote system svtidbv058 (where the clone should be go online)

 

1) SnapDrive

#############

 

Failed to connect the LUN in Snapshot copy (sqlinfo__svtidbv057__recent) as drive on the computer (SVTIDBV058).

LUN Name = Not available

Storage Path = Not available

Protocol Type = LUN

Storage System Name =

Error code : Access is denied.

#############

Contains no LUN Name!

But Storage is connected an can see all luns with snapshots. (manually connect is working!)

 

2) SnapManager for SQL

#################

 

SnapManager for SQL Server database restore to alternate location, using a writable LUN that is backed by a snapshot, failed.

Error Code: 0x80070005

Access is denied

#################

 

 

 

Seems to be an error in the SnapDrive Communication.

But what can i do now?

 

Thanks for your help

 

BR Stefan

Re: Problems with SMSQL Cloning to remote Host --> 0x80070005 Access is denied

Have you checked the service accounts for SnapDrive and SMSQL on both systems?

Shat are they and do they access rights?

Re: Problems with SMSQL Cloning to remote Host --> 0x80070005 Access is denied

Yes, i have already checked the service accounts für SnapDrive and SnapManager.

Both accounts have local administrator privileges.

Both systems (svtidbv057, svtidbv058) work locally without problems.

Only cloning to remote host cause the error.

Re: Problems with SMSQL Cloning to remote Host --> 0x80070005 Access is denied

Hi,

I've recently had the same problem as well.

To help out other ppl running into this:

If you're using two service accounts, you need to grant each of them admin rights on both maschines.

Re: Problems with SMSQL Cloning to remote Host --> 0x80070005 Access is denied

Hi,

 

I have similar problem, but probably not with permissions...

 

Clone to remote server is ending with this message.

[SERVERNAME] Error Code: 0xc004087c
Unable to find the snapinfo file from the mounted LUN in snapshot that contains the most recent snapinfo directory info
rmation.

 

After my investigation I've found, that problem is with Restore, because SnapInfo Directory is mounted with snapshot with older time.

Something like 4 days old, always.

 

SnapInfo Drive Created succesffully with such a time stamp.

----------------------------------------------------------------------------------------------------------------------------------------------------------

[SERVERNAME] Creating Snapshot of LUN/share(s):
[SERVERNAME] LUN [X]
[SERVERNAME] Snapshot name: sqlinfo__SERVERNAME_11-28-2014_14.32.03 – Created by SnapManager successfully…

[SERVERNAME] Starting SDAPI snapshot...
[SERVERNAME] Preparing LUN 'X:\', for SDAPI operation...
[SERVERNAME] Snapshot drive/share(s) successfully completed.
----------------------------------------------------------------------------------------------------------------------------------------------------------

 

But during restore to remote server ... SnapManager is trying to mount snapshot which is 4 days old....

----------------------------------------------------------------------------------------------------------------------------------------------------------

[REMOTESERVER] Restore Full Backup Set: 11-28-2014_14.32.03
[REMOTESERVER] Multiple Database Sharing Single Virtual Disk:

----------------------------------------------------------------------------------------------------------------------------------------------------------

[REMOTESERVER] Mounting Snapshot [sqlinfo__SOURCESERVER_11-24-2014_04.12.35__daily] for [X] of Computer [SOURCESERVER] – Why it is trying to connect snapshot from 24.11.2014???
[REMOTESERVER] SnapManager will use directory [C:\SMSQLMnPt] to mount snapshot [sqlinfo__SOURCESERVER_11-24-2014_04.12.35__daily]
[REMOTESERVER] Mount point directory [C:\SMSQLMnPt]
[REMOTESERVER] Snapshot will be mounted on directory [C:\SMSQLMnPt\MPDisk001]

[REMOTESERVER] Starting SDAPI mount snapshot...
[REMOTESERVER] Preparing LUN 'X:\', for SDAPI operation...
[REMOTESERVER] Mounting snapshot: sqlinfo__SOURCESERVER_11-24-2014_04.12.35__daily
[REMOTESERVER] Snapshot mount completed successfully.
[REMOTESERVER] C:\SMSQLMnPt\MPDisk001\
[REMOTESERVER] This Snapshot is mounted as LUN/share [C:\SMSQLMnPt\MPDisk001\].
[REMOTESERVER] Mount Snapshot succeeded.

[REMOTESERVER]
[REMOTESERVER] Unable to find the snapinfo file in the mounted drive/share:
[REMOTESERVER] C:\SMSQLMnPt\MPDisk001\SMSQL_SnapInfo\VDISK__D&E\FG__\11-28-2014_14.32.03\SnapInfo__11-28-2014_14.32.03.sml
[REMOTESERVER] Retrying...

Ofcourse it is unable to fund such a folder, when there is no such a folder in 4 days old snapshot ... :-(

----------------------------------------------------------------------------------------------------------------------------------------------------------

 

Anyone has any idea? Thx.

Re: Problems with SMSQL Cloning to remote Host --> 0x80070005 Access is denied

@Br Stefan - Please change the SnapDrive user account to a domain user account that has admin rights on both servers.  I would also suggest an upgrade of both SDW and SMSQL, as those versions are quite old and out of support.

 

@patrick - What versions of SDW and SMSQL are you running?  We are aware of an issue with SMSQL 7.0/7.1 that exhibits the exact behavior you are seeing.  There is a patch release currently available that addresses this issue, so if you are running the SMSQL 7.x code line, please contact NetApp Support for assistance in obtaining the patch.

Re: Problems with SMSQL Cloning to remote Host --> 0x80070005 Access is denied

@ANDYD: SnapManager for SQL Server Version : 7.1.0.2024_140603_0415 and SnapDrive : 7.0.3

 

Windows 2008 R2 + SQL 2012

 

Security settings are same on both servers.

Re: Problems with SMSQL Cloning to remote Host --> 0x80070005 Access is denied

@Patrik - Yes, you are most likely a known bug in SMSQL (See bug report here: http://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=847188).  Please contact NetApp Support for assistance in obtaining the SMSQL 7.1 patch release in order to resolve your issue.

Re: Problems with SMSQL Cloning to remote Host --> 0x80070005 Access is denied

Thx for your help, already contacted NetApp Support, waiting for reply.

Re: Problems with SMSQL Cloning to remote Host --> 0x80070005 Access is denied

My problem solved by updating SnapManager to version 7.1P1 :-) Thx.