Subscribe

Protection Manager and SMSQL

We are installing MS SQL2005 on a Win2003 and are using SMSQL 5.0R1, SnapDrive 6.1.

On DFM / Protection Manager we configured a policy for the SQL, in SD we enabled PM.

When running the config wizard in the SMSQL we see the step "Data Protection" on the left side, but while stepping through the configuration the "Data Protection" part is skipped - no chance to enable the databases for PM or selecting the policy. Thus no Dataset is created in PM.

What could cause this behaviour?


THX

Markus

Re: Protection Manager and SMSQL

Hi Markus,

The reason for that could be that the databases are not on QTREE LUNs. Please ensure that the databases for which you want to enable backup archival are on QTREE LUNs wherein there should be only one LUN per QTREE.

Additionally, please run the following command and send the output: -

sdcli snapvault verify_configuration [-m

MachineName]

Regards,

Sourav.

Re: Protection Manager and SMSQL

Dear Sourav

Please ensure that the databases for which you want to enable backup archival are on QTREE LUNs wherein there should be only one LUN per QTREE.

As it is also stated in the SMSQL admin-guide for the requirements for SnapVault integration - so I checked it again:

         /vol/iscsi_mssql2k5_lab_db/db/mssql2k5_lab_db_n.lun    3.5g (3750727680)    (r/w, online, mapped)
        /vol/iscsi_mssql2k5_lab_log/log/mssqkl2k5_lab_log_l.lun    3.5g (3758952960)    (r/w, online, mapped)
        /vol/iscsi_mssql2k5_lab_si/si/mssql2k5_lab_si_s.lun    3.5g (3750727680)    (r/w, online, mapped)
        /vol/iscsi_mssql2k5_lab_si/sys/mssql2k5_lab_sys_m.lun    1.0g (1126863360)    (r/w, online, mapped)

nope ...

But it is a pitfall, in which I just trapped today at another customer. Thanks a lun move into a qtree is non-disruptive :-)

But that it seems, that PM needs some time to reflect the changes, 'cause before the break nothing worked, after the break everything was fine.

Back to the initial problem:

Strangewise it was resolved by changing the SD dfm_config from HTTP to HTTPS:

sdcli dfm_config set -host dfm-lab -user ... -pwd ***** -port 8488 -type https

Seems like dfm server was not listening on port 8088.

Regards

Markus