Subscribe

RPC server not available check Dcom ports or Windows firewall

[ Edited ]

Server info:

OS : Windows 2008

Snapdrive 6

Snap manager 5

Error : RPC server not available check Dcom ports or Windows firewall while connecting disk in snap drive,

am using 2 servers in cluster mode, act as exchange server. in primary server am getting above error, because of that am not able to take backup & verify in snap manager.

note : firewall service is stop only, not disabled.

Pls help me to sort out of this issue,

Re: RPC server not available check Dcom ports or Windows firewall

I replied to you in a PM, but thought I'd share this with the general community as well...in case anyone else hits this...


Even though you have stopped your firewall, it still may be blocking the ports that are necessary for SnapDrive to communicate with the other SnapDrive instance. To ensure the firewall is not an issue here, we'll need to configure it to allow SnapDrive communications.

Here's an excerpt from the SDW 6.0 IAG...linked below...

http://now.netapp.com/NOW/knowledge/docs/snapdrive/relsnap60/pdfs/admin.pdf

Enabling SnapDrive to communicate through the Windows Firewall

If the Windows Firewall is enabled on your host, you need to configure it to allow SnapDrive for Windows communications. The Windows Firewall is enabled by default in Windows Server 2008.

Steps

1. Add the DCOM registry key using regedt32, as described in the Microsoft technical article, "Using Distributed COM with Firewalls," available from the Microsoft Developer Network library at http://msdn2.microsoft.com/en-us/library/ under Win32 and COM Development ➤ Technical Articles ➤ Component Development ➤ DCOM.

2. Navigate to Control Panel➤Windows Firewall➤Allow a program through Windows Firewall ➤ Exceptions.

3. Select the COM+ Network Access checkbox.

4. If you will be using HTTP or HTTPS, select the World Wide Web Services (HTTP) or Secure World Wide Web Services (HTTPS) checkboxes.

5. Click Add program and browse to C:\Program Files\NetApp\SnapDrive\, or to wherever you installed SnapDrive if you did not use the default location.

6. Select SWSvc.exe and click Open, then click OK in the Add a Program window and in the Windows Firewall Settings window.

7. Reboot the system.

Repeat these steps on both systems that are making up the Exchange cluster. Also, if you're using a Remote Verification server with SME, these steps will have to be done on the Remote Verification server as well.

Let me know if this fixes your problem...

Shannon

Re: RPC server not available check Dcom ports or Windows firewall

Hello,

I have exactly the same problem. However, I followed the Firewall setup and it still have the same problem.

I have tried to turn-off the firewall but no good.

Anyone can help? Thanks.

Raymond

Re: RPC server not available check Dcom ports or Windows firewall

Hi Raymond...

Not to sound repetitive, but the Firewall was completely off (Domain, Private, & Public). Are there any policies on the system that prevent certain types of communications between systems?

Thanks

Shannon

Re: RPC server not available check Dcom ports or Windows firewall

Hi Shannon,

I found that the startup user account for snapdrive service MUST use domain account. Otherwise, there will be the "Access is denied" error. It was not the same behaviour as Win2003.Everthing works fine now.

Thanks.

Re: RPC server not available check Dcom ports or Windows firewall

Good to hear Raymond.

Thanks...

Shannon