Subscribe

Restore problem "The data is invalid"

Model: FAS2040

OnTap version: 8.1.1 7-mode

OCUM version: 5.2

OSSV client version: 3.0.1P5

OSSV host OS: Windows Server 2012R2

 

Certain files cause OSSV restore jobs to get stuck. Instead of skipping these files the whole restore process halts. For example:

 

Restoring a 100MB folder. First 30MB or so gets restored fine, but it seems that when the first broken file is encountered the restore stops. Restores are being done through OCUM, and OCUM gives the following error:

 

RUSMOWFILE2: Error restoring D:\Restore\xxx\yyy.xlsx: The data is invalid

 

 

 

In OCUM the job stays active, but no progress is made. When viewed from the filer the snapvault restore relationship is in transferring state at around 20-50MB transferred, but it doesn't progress at all.

 

Broken files are not all of the same format, but most of them are xlsx excel files with some .PDF and .DB files in the mix. OSSV host is a file server and these files are in a shared folder on the server. There are cyrillic alphabet in the folder and filenames, but that doesn't seem to be the issue. I've managed to restore folders and files with cyrillic filenames and there are broken files without cyrillic symbols in their paths. This leads me to believe that volume or any other language setting isn't a likely cause.

 

Older servers with 2008 or 2008R2 operating systems don't seem to have this problem. Only newer 2012R2 server are affected as far as I know.

 

In short, there are two questions.

 

1. Can these "invalid data/corrupted" files be either salvaged or skipped somehow in the restore process? Manually selecting and deselecting files in a large file share restore isn't a practical solution.

2. What has caused the corruption in the files? How can we avoid this in the future?

Re: Restore problem "The data is invalid"

Hi,

 

Are you using winodws 2012 deduplication feature? Is the windows volume which has deduplication enabled backedup?

 

Thanks

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Restore problem "The data is invalid"

Hello DEEPUJ,

Thank you for your answer!

Very good question, because deduplication settings on my volumes of WS2012R2 servers is enabled. I will test backup and restore without deduplication and will inform you!

Re: Restore problem "The data is invalid"

Good one thanks. This was helpful.

Re: Restore problem "The data is invalid"

Oh, sorry for delay.

Yea, it helps. 

If you turn off your windows server deduplication - netapp restore is okay.

Looks like NetApp not support windows server 2012 deduplication...?