Subscribe
Accepted Solution

SC 3.4.0 change default SC server port on Windows Server 2008 R2

[ Edited ]

Hello.  I am looking for assistance.  I am working with SC 3.4.0 (64-bit) on Windows Server 2008 R2.  During the install wizard I changed the default location of install from the C volume to D volume and default SCserver port from 8080 to 8081 and the default SC agent from 9090 to 9091 because other services are already using the default SC ports.  The SCagent service seems to be up and running fine, however, the SC server service will not start.  I believe that when the SC server was registered as a service the 8081 parameter was not set correctly?  The Windows Service forthe SC server shows its path to the executable as:

"D:\ProgramFiles\Netapp\NetApp_Snap_Creator_Framework\scServer3.4.0\gui\prunsrv.exe"//RS//SnapCreatorServerService

Contrast this to the SC agent (where there is clearly port specified)

D:\Program Files\Netapp\NetApp_Snap_Creator_Framework\scAgent3.4.0\scAgentService.exe--start-agent 9091

Attempting to launch prunsrv.exe results in:

D:\ProgramFiles\NetApp\NetApp_Snap_Creator_Framework\scServer3.4.0\gui>prunsrv

[2011-07-15 14:32:51] [warn]  The system cannot find the Registry keyfor service 'prunsrv'

[2011-07-15 14:32:51] [error] Load configuration failed

[2011-07-15 14:32:51] [error] The system cannot find the file specified.

[2011-07-15 14:32:51] [error] Commons Daemon procrun failed with exit value:2 (Failed to load configuration)

[2011-07-15 14:32:51] [error] The system cannot find the file specified.

What steps can be taken to troubleshoot this?

Thank you.

SC 3.4.0 change default SC server port on Windows Server 2008 R2

Install 64 bit version of java

Try running gui manually without service

cd to scServer3.4.0\gui

java.exe -jar snapcreator.jar -gui_port 8081

Look in gui/logs directory

Hope this helps

Keith

SC 3.4.0 change default SC server port on Windows Server 2008 R2

Thank you for the fast reply.  The key was installing the 64-bit version of Java.