Subscribe
Accepted Solution

SC4.1P1 registers the same backup in PM over and over again

[ Edited ]

Hi,

I'm scratching my head here to try and understand what's going on in my lab.

I am testing 3 different architectures - "direct" where SC speaks directly to filers, "proxy" where OnCommand acts as a proxy and "hybrid" - direct connection to primary filer, DFM manages vaulting.

So for the proxy and hybrid cases, where Protection Manager is involved, whenever I run a backup job, the snapshot on the primary is created OK but for some reason, that's not the info that's sent over to Protection Manager.

SC sends the oldest/first (not the latest) snapshot over...

PS C:\Users\Administrator\Desktop> dfpm backup list snapcreator_files_vega

Backup Id Backup Version        Retention Type Retention Duration (in seconds)   Node Name            Description     Properties(Name=Value)

--------- --------------------- -------------- --------------------------------- -------------------- ------------------ ----------------- -------------------------

     1202 15 Apr 2014 08:50:26  hourly                                           Primary data         SnapCreator 4.0 Backup

Only one backup registered.

Running a new one an 09:19, checking audit.log in OCUM, same backup/snapshot gets registered again!?!?

Dataset On-Demand protection job sets off and finishes OK but since there is no new registered backup to protect on the Primary, nothing gets transferred.

Apr 15 09:19:00 [Unknown:NOTIC]: administrator:API:in:[10.68.73.179]::<dp-backup-version-create>  <backup-description>SnapCreator 4.0 Backup</backup-description>  <dataset-name-or-id>snapcreator_files_vega</dataset-name-or-id>  <retention-type>hourly</retention-type>  <version-timestamp>1397544626</version-timestamp>  <version-members>   <version-member-info><snapshot-unique-id>1397544626</snapshot-unique-id><snapshot-name>files-hourly_20140415085025</snapshot-name><volume-name>vega:/testvol4</volume-name><snapshot-contents> <snapshot-member-info>  <primary-name>vega:/testvol4/-</primary-name> </snapshot-member-info></snapshot-contents>   </version-member-info>  </version-members> </dp-backup-version-create>

Any clues or ideas?

Thanks in advance,

Erik

Re: SC4.1P1 registers the same backup in PM over and over again

Erik,

Are you using 7-Mode or clustered Data ONTAP?

I'm guessing 7-Mode.

We recently uncovered a bug (last week) in 7-Mode systems where the Regex expression is matching the oldest Snapshot copy instead of the newest.

In the other instance the customer decided to use Snap Creator 4.0 for now which apparently does not have this bug.

The bug is slated to be fixed in the 4.1P2 patch, roughly expected in May.

Thanks,

John

Re: SC4.1P1 registers the same backup in PM over and over again

Thanks John,

Yes, this is 7-mode. I'll give 4.0 a try.

Cheers,

Erik