Subscribe
Accepted Solution

SDW 6.2: sdcli/storacl fail to load SnapDriveRes.dll for non domain admin

SDW 6.2 was installed under domain administrator account on 2008 R2. I try to run it using local domain (member of BUILTIN\Administrators) account. GUI works just fine. But CLI fails, both sdcli and storacl:

C:\Users\user3>\temp\storacl_x64\storacl.exe


Create Instance of Loader to load SnapDriveRes.dll failed

C:\Users\user3>

Is it a known issue?

Re: SDW 6.2: sdcli/storacl fail to load SnapDriveRes.dll for non domain admin

Looks like "en-US\SnapDriveRes.dll" is missing in the current folder. Tryout extracting the storacl_x64.zip file properly.

Thanks,

Prasad

Re: SDW 6.2: sdcli/storacl fail to load SnapDriveRes.dll for non domain admin

We had the same problem

You have to run CMD.EXE with administrator privileges (right click --> "Run as administrator"). UAC does prevent you from running cmd as local admin, even if you are loggedwith an administrator.

Re: SDW 6.2: sdcli/storacl fail to load SnapDriveRes.dll for non domain admin

I confirm that after disabling UAC it works. By default W2k8 comes with local policies Admin approval for Built-In Administrator = disabled and Run all administrators in Admin Approval = enabled, which explains why it did work for domain admin (I was on domain controller where domain admin == local admin). Changing Behaviour of elevation prompt for administrators to Elevate without prompting does not fix it.

In plain words it means that RBAC with SDW CLI is impossible with UAC enabled. Not nice ...