Subscribe

SME verification on an ESX VM over FCP

[ Edited ]

I am having issues with the Exchange verification process when the remote verification service runs on a VM.  The ESX 3 server has the NetApp FCP host kit but I keep on getting the FCP partner misconfigured error.  I can not yet upgrade to vSphere so I have a cron job which sets the MPIO path every hour.  However this is not enough for the verification job as it has 8 luns in two volumes.

Any advise please?

Thanks

Bren

Re: SME verification on an ESX VM over FCP

This is the filer error:

FCP Partner Path Misconfigured - Host I/O access through a non-primary and non-optimal path was detected.

lun stats -o
    /vol/sdw_gbdc02exmbf02db_cl_exchsnap__gbdc01exmbv02_09282009_190043__daily_ss_0/sg1db.lun  (0 hours, 0 minutes, 23 seconds)
        Read (kbytes)   Write (kbytes)  Read Ops  Write Ops  Other Ops  QFulls  Partner Ops Partner KBytes
        32614           57              8203      16         124        0       8309        32671

Re: SME verification on an ESX VM over FCP

Just curious -- what specific command (with its switches) are you using to set the paths?

Re: SME verification on an ESX VM over FCP

This is how I made the pain go away for the none SME/SMSQL verification

ESX servers. What you want is in step 4).

Hope it helps

Does not work with verification due to luns mounting and unmounting all

the time during the jobs. Think setting the cron to every 1 minute

would address the issue but that is a very ugly solution.

Bren

Solution

1. Log into the ESX host's Service Console with root/su permissions.

2. Run the command vi /etc/crontab

root@esxserver etc]# vi /etc/crontab

SHELL=/bin/bash

PATH=/sbin:/bin:/usr/sbin:/usr/bin

MAILTO=root

HOME=/

  1. run-parts

01 * * * * root run-parts /etc/cron.hourly

02 4 * * * root run-parts /etc/cron.daily

22 4 * * 0 root run-parts /etc/cron.weekly

42 4 1 * * root run-parts /etc/cron.monthly

3. Go to the end of the last line of the file by using arrow keys. Press

the 'a' key to change to INSERT mode.

4. Press Enter to start a new line in the file. The first number in the

string will determine what minute past the hour the script will run.

This example shows the command running hourly at 5 minutes past the

hour. The config_mpath options can also be modified to fit your needs

(example: adding --secure would ensure that the script runs over SSL):

5 * * * * root echo "config_mpath --primary --persistent --policy

fixed --loadbalance"

5. Press the ESCAPE key to exit INSERT mode.

6. Press the colon ':' key, then 'wq'

7. Press enter to save the changes to the file.

Re: SME verification on an ESX VM over FCP

When setting the preferred path through the FCP utilities did you set the primary, persistent, and load balancing policy? Once setting this it fixed our misconfigured path.

config_mpath --primary --loadbalance --persistent --policy fixed

Re: SME verification on an ESX VM over FCP

The partner misconfigured error could be a couple of different thing.  It could be something as simple as a configuration issue or it could also mean that the primary path between the host and the storage has failed.  Is this something that happens only during verification or at other times as well such as during the SnapMirror process.  Is this just something that is failing during the verification process?

Sorry I couldn't provide more details,

Brad

Re: SME verification on an ESX VM over FCP

Verification was failing due to a mis-configured Riverbed 'playing' with the snapmirror traffic.  This has been sorted and I am just left with intermittent fcp errors but everything is working.

Thanks for the help anyway

Bren