Subscribe

SMMOSS - Unable to Detect Farm Information

[ Edited ]

Afternoon All,

I am getting an irritating issue when configuring SnapManager for SharePoint in a farm. I was hoping someone could point me in the right direction?

Here is my setup:

SharePoint 2010 Farm:

Sp-web1 and Sp-web2 are a both Web Front Ends.

Sp-app1 is a SharePoint Search/Indexer and Office application server.

Sp-SQL1 is the database server.

Sp-SQL1 has Snap Manager for SQL (not configured yet) and the SharePoint Media and Manager Roles. It also has the SnapManager agent running as a SMMOSS Member Agent.

All other servers have the SMMOSS agent installed.

All agents are showing in the Management console, but I am not able to change any options as they are greyed out. I think this is because I haven’t installed any agents as ‘SMMOSS Control Agent’. This should be applied on the web front ends, but it doesn’t let me Smiley Sad.

The snap drive service account has Farm Administrative and Local Admin rights across the farm.

When looking in the event log, I am getting a couple of 'Informational Errors':

smmoss,0.0 [agent version=5.0.0.0]

non sharepoint or get farmname error: system.nullreferenceexception: object reference not set to an instance of an object.

at smmoss.common.registerparameters.getfarmname()

Any ideas?

Thanks,

Paul

get total memory size is fail.system.management.managementexception: invalid class

at system.management.managementexception.throwwithextendedinfo(managementstatus errorcode)

at system.management.managementobjectcollection.managementobjectenumerator.movenext()

at smmoss.common.aveloadbalance.gettotalmemorysize()

SMMOSS - Unable to Detect Farm Information

You need to give access in SQL to the Databases you want to have backed up by SMMOSS, maybe this step got forgotten?

Peter

SMMOSS - Unable to Detect Farm Information

Thanks Peter.

I have checked the permissions and the service account (Agent Run-As) has sysadmin across the SQL Server. Is this correct?

The account is also local administrator across the board.

Thanks

SMMOSS - Unable to Detect Farm Information

Actually there is some place within the SQLDB Admin Tools, where one can manage access to the data within SQL. Thats where it needs access too. I'm not a SQL Admin, but had them do this a couple of times in the last years...

Hope this helps.

Peter

SMMOSS - Unable to Detect Farm Information

Thanks Peter. I have now checked all ther permissions on both SQL and Windows (the SQL permissions you talk about are 'View Server State' at the server level, and it must also be mapped as DB_Owner on all databases). However, I am still getting the issue where it cannot detect any sharepoint configuration. I have narrowed this down to not having a Control Agent installed anywhere on the farm (it wont let me choose that option).

Is there anything else you can think of that may be stopping me from choosing this option during the Agent Installation?

If any one else is wondering what permissions are required across Windows/SQL, they should be:

Windows

Local Administrator on all servers where a SMSPagent is installed - where a group policy with restrictive settings isinstalled, check the local security policy for each server (Run >gpedit.msc > Windows Settings > Security Settings > Local Policies> User Rights Assignment) and ensure the following permissions:

  • Log on local
  • Log on as batch job
  • Log on with System     Interactively (Windows 2003 only)
  • Log on as a Service
  • Replace a process level     token
  • Act as part of the operating     system

SharePoint Central Admin

  • Farm administrator (This     account must be in the Farm Administrator group as a member, but not a member     of a group which is then applied into this group.)
  • Site collection     administrator
  • Full control under the web     application user policy (Application Mgmt > Manage Web Applications     > select the Web Application > click User Policy in the     menu bar)
  • Owner of application pool (Security     > General Security > configure service accounts)

SMSP Manager

  • A member of the     Administrators group (SMSP Control Panel > SMSP Services >     Account Manager)
  • Owner of each agent (SMSP     Control Panel > SMSP Services > Control Service > Agent Monitor     > Configure)

SQL Server Mgmt Studio

  • Server roles of process     admin, public, security admin, sysadmin (Security > Logins >     right-click the account > Properties)
  • dbowner for each SharePoint     database (check user mappings)
  • View server state needs to     be checked (right-click the server name > Properties >     Permissions)

Re: SMMOSS - Unable to Detect Farm Information

Yes, if you have no Control Agent, this error is normal.

1. downloaded the "**_Agent.exe" from NOW?

2. installed this agent package on the WebFrontend Server?

Peter

PS thanks for the access overview!

Re: SMMOSS - Unable to Detect Farm Information

Thanks Alex,

I have manually install SMMOSS50_Agent.exe on all front ends. I am able to validate the connection to the SMMOSS manager, but when asked to choose the Agent Type, both options Member and Control Agent are greyed out.

Thanks,

Paul

SMMOSS - Unable to Detect Farm Information

how about the different IP Ports needed for communication?

attached you see the agent config on my webfrontend server (names removed)...

Peter

Re: SMMOSS - Unable to Detect Farm Information

Cheers Alex,

I will try and use another port. I am able to Telnet to all the ports outlined in https://kb.netapp.com/support/index?page=content&id=2014035, which would suggest the ports and open and are not conflicting.

Here is my Agent configuration (with names and IPs removed). It is as though the application can't detect Sharpoint is installed. Does the application only search the default install path (C:\Program Files\Sharepoint)? I have install Sharepoint to a seperate drive.

Thanks


SMMOSS - Unable to Detect Farm Information

Alex?... Peter

You're sure you are running 5.0? The gui looks very different... Could it be you installed the "complete" manager package on this server?

Peter