Subscribe

SMSP 2010 granular restore database mount problem

[ Edited ]

hello there,

We currently have a sharepoint 2010 implementation running the following virtual (esx 4.1) windows 2008 R2 servers:

2 x Index servers

     - Member Agent

     - Control Agent

     - SDW - iSCSI lun.

2 x WFE servers

     - Member Agent

     - Control Agent

     - SDW - iSCSI lun

1 x (clustered SQL server - 2 nodes) Active/Passive

     - Member Agent

     - smsql

     - SDW - FC luns (shared, mapped using snapdrive)

1 Media server with SnapManager for SP manager

     - Media Server

     - SP SnapManager   

     - SDW - iSCSI lun

the clustered database (MSCS) is configured as per vmware recommended configuration - FC Luns over physical passthrough RDMs with mapping files on vmfs iscsi lun.

We have successfully configured a backup job and can browse the farm components. We cannot select the associated database indexes when we create the backup job. However, jobs complete successfully although we have two issues with restores.

  • As we cannot select to backup the indexes, browsing granular restores using the index is not available

  • So the second problem arises when trying to browse granular restore data using the 'From Backup Data' option. When selected, Snapdrive attempts to mount the snapshot created in the backup and generates the following error:

'Restored temp content database failed, database name: WSS_dbname'

we recieve an email from snapdrive on the cluster:

[SnapDrive Error]: Operating System does not support mounting shared disk on non-shared volume. Please change disk type or select different mount point.

So, firstly, what reasons might the index not be available to backup or restore from.

and secondly, any help with the db mount would be very much appreciated!

Many thanks in advance

Andy

Re: SMSP 2010 granular restore database mount problem

Try changing the location of your SnapMgr mount point. By default this will be on a non clustered disk. Snapdrive will fail to mount a cluster disk (job 2 of SMSharepoint item level backup) on a non clustered volume (eg. c:\program files\netapp\snap manager for sql\...). Try changing it to point to one of your clustered disks (eg. G:\)

Couldn't find anywhere to change default in smsql. Create a folder and modified the reg key and was able to do a item restore in SP2010.

  • HKLM\Software\Network_Appliance\SnapManager for SQL Server\Server\MountPointDir

Let me know if this works ok for you.

SMSP 2010 granular restore database mount problem

That's work.  Thanks Jodymartin.

Looks like there is an open issue for this

http://communities.netapp.com/thread/14709