Subscribe

SMSP permissions issues - db_owner Permission to Stub Database

Hello,

We're working on SMSP implementation and currently have some issues.

One main error is being seen on application servers / frontend severs.

According the error, the Agent account doesn’t have db_owner permissions.

The thing is that the agent user is the farm admin, we checked on SQL MGMT Studio and it seems to have all the permissions (on user mapping, “dbo” appears on the reported database, and on the SharePoint databases).

Also, Farm is not being seen via the Backup tab. I guess it’s related to the errors described in Health Analyzer.

Will be happy if you suggest ways to troubleshoot this.

 

This is the error message (for both modules “Connector” and “Storage Manager”:

  • Rule: db_owner Permission to Stub Database.
  • Module: Connector + Storage Manager
  • Farm: Farm(SQLSERVERSmiley Very HappyBNAME_sharepoint_config)
  • Hostname: …
  • Sub-Category: SQL Permissions
  • Status: Error
  • Result
  • Explanation: The rule checks whether or not the Agent account has the db_owner permission to the stub database. The Agent account needs this permission to create the stub database table, and also create, delete, and update stubs.
  • Solution:
  1. Log in to the SQL Server Instance where the stub database resides.
  2. Navigate to security > Logins.
  3. Locate the Agent account. If the Agent account does not exists, add it.
  4. Double-Click the Agent account. The Login Properties pop-up window appears.
  5. Click User Mapping in the left navigation.
  6. In the Users mapped to this login field, select the stub database by selecting the corresponding checkbox.
  7. In the Database role membership for field, select the db_owner checkbox.
  8. Click OK to save your changes.

 

Environment Versions:

  • SMSP 8.2
  • SharePoint 2013 SP1
  • Windows 2012 R2
  • SQL 2012

 

Thanks !