Subscribe

SMSQL always states Job completed successful although nothing was done

[ Edited ]

Hi Everybody

While deploying SnapManager SQL on one Test Machine I noticed something odd.

Regardless of what incorrect Parametes I set in SnapCreator for the SMSQL Plugin, the Job always is stated as Completed.

I'll attach some examples, one that works (CH_TR_SQL_NTRLA172) and two with totally silly Parameters for Powershell Path and Parameters.

All three are stated as ok in SnapCreator but only the first actually does anything.

Is this really how the Tool is supposed to react? Every other Major Vendor would treat that as a major Bug.

Or did I miss to set up some additional checking in my Configuration?

Thanks for your Help

Stefan

Re: SMSQL always states Job completed successful although nothing was done

Yes this is a bug

SC 3.6 did not properly get the results back from powershell. Since we spawn a shell which then executes powershell you have to get the results of both.

This is fixed in SC 4.0 which will be available in March 2013.

SC allows you to pretty much do anything, you can run commands on agents, runs scripts, create plugins, of which you can use any language. While I do agree we should not miss such bugs in QA cycles, few other products provide the extensibility and flexibility that SC does. Not making excuses just saying we havent made life particularily easy for QA ;D This is where you can help if you so choose to

SC has a developer community www.snapcreator.com where we release community versions of the product. This comes out around 3 months before the release of the supported NetApp version to NOW. Anyone can test anything they want and if bugs are found we do our best to address them prior to release of the supported product.

SC 4.0 which releases in March has community version already available:

https://snapcreator.netapp.com/download

Regards,

Keith

Re: SMSQL always states Job completed successful although nothing was done

Hi Keith

Company Policies prevent us from using Releases that are not supported directly by the Vendor, so we are stuck to wait till 4.0 is considered stable.

But it is good to know that the Bug was found and will be fixed soon, thanks for clarifying that.

SnapCreator is flexible indeed, but for my taste to unstable and not enough straight forward so far.

I know you are working hard on improving it (Sebastian Hegmanns told me some stories), looking forward to 4.0

Off the actual topic:

Executing Powershell-Commands with the Agent in 3.6 is a bitch.

We have a Symantec EnterpriseVault Environment which we would like to pause with some sequencial Powershell-Commands.

Unfortunately it always gets stuck with the frst command (regardless which it is). Powershell executes the Command but does not return and close, keeping the other Commands from being executed.

Hope this is also a similar bug and is fixed with 4.0 too.

Freundliche Grüsse / Kind Regards

Stefan Vollrath

T-Systems Schweiz AG

Storage & Backup Operations

Stefan Vollrath

Storage Engineer

Murgenthalstrasse 12, CH-4901 Langenthal

+41 (0) 78 645 1076 (phone)

E-Mail: stefan.vollrath@t-systems.com

http://www.t-systems.ch <http://www.t-systems.ch/>

Notice: This transmittal and/or attachments may be privileged or confidential. If you are not the intended recipient, you are hereby notified that you have received this transmittal in error; any review, dissemination, or copying is strictly prohibited. If you received this transmittal in error, please notify us immediately by reply and immediately delete this message and all its attachments. Thank you.

Von: Keith Tenzer

Gesendet: Dienstag, 5. Februar 2013 11:58

An: Vollrath, Stefan

Betreff: - Re: SMSQL always states Job completed successful although nothing was done

NetApp Online Community <https://communities.netapp.com/index.jspa>

<http://media.netapp.com/images/divider-600x3.jpg>

Re: SMSQL always states Job completed successful although nothing was done

created by Keith Tenzer <https://communities.netapp.com/people/ktenzer> in Snap Creator - View the full discussion <https://communities.netapp.com/message/99606#99606> <http://media.netapp.com/images/divider-600x3.jpg>

Yes this is a bug

SC 3.6 did not properly get the results back from powershell. Since we spawn a shell which then executes powershell you have to get the results of both.

This is fixed in SC 4.0 which will be available in March 2013.

SC allows you to pretty much do anything, you can run commands on agents, runs scripts, create plugins, of which you can use any language. While I do agree we should not miss such bugs in QA cycles, few other products provide the extensibility and flexibility that SC does. Not making excuses just saying we havent made life particularily easy for QA ;D This is where you can help if you so choose to

SC has a developer community www.snapcreator.com where we release community versions of the product. This comes out around 3 months before the release of the supported NetApp version to NOW. Anyone can test anything they want and if bugs are found we do our best to address them prior to release of the supported product.

SC 4.0 which releases in March has community version already available:

https://snapcreator.netapp.com/download

Regards,

Keith

Reply to this message by replying to this email -or- go to the message on NetApp Community <https://communities.netapp.com/message/99606#99606>

Start a new discussion in Snap Creator by email <mailto:discussions-community-products_and_solutions-databases_and_enterprise_apps-snapcreator@communities.netapp.com> or at NetApp Community <https://communities.netapp.com/choose-container.jspa?contentType=1&containerType=14&container=2481>