Subscribe

SMSQL remote verification timeout

[ Edited ]

Hi

as we all know it is no problem to backup even very large databases (https://communities.netapp.com/message/87965#87965 ), and verification can be completely offloaded to another storage controller and SQL server.

IHAC who did exactly such an offload and now gets a timeout error:

...

[01:10:37.956]  [CHDB018] WARNING: Federated remote backup threads timed out after [480] minutes.

...

Does anyone know a way (registry key?) to adjust the timeout value?

thx

Markus

Re: SMSQL remote verification timeout

Hi,

I'm having the same problem.

Did you solved it? How?

By the way as the verification job failed I have the database attached, the vmdks linked to the vm, the datastores presented, and the volumes cloned. Do I have to revert all this automatic work made by SMSQL manually?

Thank you very much in advance and best regards.

Javier

Re: SMSQL remote verification timeout

Hi,

After opening a case with NetApp support service I have finally solved this issue.

The solution is to modify (or add if we don't have it) a registry key named RemoteBackupThreadTimeout located in HKEY_LOCAL_MACHINE\SOFTWARE\Network Appliance\SnapManager for SQL Server\Server, that is used as timeout for remote backup threads. This key is a DWORD and indicates number of minutes. Its default value is 480 (minutes).

  1. Click Start, and then click Run on the SMSQL server.
  2. Type regedit, and then click OK.
  3. Click the '+' sign next to 'HKEY_LOCAL_MACHINE' in the left pane of the Registry Editor window.
  4. Navigate to the below registry entry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Network Appliance\SnapManager for SQL Server\Server
  5. Add DWORD (32-bit) value named 'RemoteBackupThreadTimeout' and set it to a number larger than 480 (default value in minutes).

There is no need to restart SMSQL service after this change.

Regards.