Subscribe

Snap operation failing on Oracle LINUX 6.3 host with error in SSLeay perl module

[ Edited ]

Hey Guys,

Just installed 3.6p1 on RHEL 6.3 and got the following error when trying to run a backup.

Subroutine AUTOLOAD redefined at
        /</opt/netapp/scServer3.6p1/snapcreator>Net/SSLeay.pm line 651 (#1)
    (W redefine) You redefined a subroutine.  To suppress this warning, say

        {
        no warnings 'redefine';
        eval "sub name { ... }";
        }

Subroutine print_errs redefined at
        /</opt/netapp/scServer3.6p1/snapcreator>Net/SSLeay.pm line 688 (#1)
Subroutine die_if_ssl_error redefined at
        /</opt/netapp/scServer3.6p1/snapcreator>Net/SSLeay.pm line 704 (#1)
Subroutine die_now redefined at
        /</opt/netapp/scServer3.6p1/snapcreator>Net/SSLeay.pm line 712 (#1)
Subroutine blength redefined at (eval 255) line 1 (#1)

Can't load 'auto/Net/SSLeay/SSLeay.so' for module Net::SSLeay: auto/Net/SSLeay/SSLeay.so: cannot open shared object file: No such file or directory at /</opt/netapp/scServer3.6p1/snapcreator>DynaLoader.pm line 219.
at perlapp line 843 (#2)
    (F) The module you tried to load failed to load a dynamic extension. This
    may either mean that you upgraded your version of perl to one that is
    incompatible with your old dynamic extensions (which is known to happen
    between major versions of perl), or (more likely) that your dynamic
    extension was built against an older version of the library that is
    installed on your system. You may need to rebuild your old dynamic
    extensions.

Uncaught exception from user code:
        Can't load 'auto/Net/SSLeay/SSLeay.so' for module Net::SSLeay: auto/Net/SSLeay/SSLeay.so: cannot open shared object file: No such file or directory at /</opt/netapp/scServer3.6p1/snapcreator>DynaLoader.pm line 219.
at perlapp line 843
at perlapp line 950
        PerlApp::my_require('Net/SSLeay.pm') called at snapcreator.pl line 8869
        main::setEnv() called at snapcreator.pl line 666
[root@houks1 scServer3.6p1]# perl version
Can't open perl script "version": No such file or directory
[root@houks1 scServer3.6p1]# perl -version

This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi

Copyright 1987-2009, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.

[root@houks1 scServer3.6p1]#

Any thoughts?

Take Care,

Paul

Re: Snap operation failing on Oracle LINUX 6.3 host with error in SSLeay perl module

Snap Creator does not include ssl libraries we are dependent on, therefore customer must install openssl and ensure symlinks are created correctly (see below).

The reason is simply we dynamically link so customers can update SSL versions of openssl for important security fixes without being dependent on SC versions.

The requirements for HTTPS for Linux/Unix are as follows:

1) openssl package   (yum install openssl)

2) SSL symlinks

Make sure the following symlinks are located under /usr/lib oder /usr/lib64 (depending on if OS is 64bit or not)

libssl.so.6

libcrypto.so.6

If the symlinks dont exist please cd to /usr/lib or /usr/lib64 and run following command to link them. Make sure what we are linking to is installed, again pre-requisite is openssl so it should be installed first.

ln -sf libssl.so.0.9.8 libssl.so.6

ln -sf libcrypto.so.0.9.8 libcrypto.so.6

#########If you still have issues, you could try downloading this Net SSLeay packages from here, but I don't see a need for it, yet#############

http://cpansearch.perl.org/src/SAMPO/