Subscribe

SnapCenter 1.1 NFS Volume Backup with VSC Fails on New-NcSnapshotMulti

We have a new installation of SnapCenter 1.1 connected to our VMware vCenter server (6.0U2) and all seems well until we try to schedule and run a backup script.  I can setup the task without any issue, but everytime I attempt to run it it fails with the following error:

 

" Create snapshot 'Test_CL-VSC-7VUS01_05-20-2016_15.13.27.5960' failed: Error: Snapshot operation failed. Failed to run a command New-NcSnapshotMulti" 

 

I've veried the storage connections and users are correct and everything else seems to work just fine.  The volume I'm trying to backup is NFS based.  Any suggestions on how to fix this? 

Re: SnapCenter 1.1 NFS Volume Backup with VSC Fails on New-NcSnapshotMulti

I added my experience to a similar post see below

 

Hoping this will help somebody

 

First thing is that NetApp support is getting better with snapcenter just finished work on a case with them and we did get to the bottom of it.

 

It also highlight the early stages for snapcenter. If you look at the logs it clearly states that New-NcSnapshotMulti is meant to be run against an svm... not a cluster. Snapcenter wants SVM.

 

Well if you already have the VSC running and try to transition to snapcenter it just doesn't seem to work. VSC likes clusters it will gather all the info regarding the SVM an populate it. The solution in our case was to cleanup the VSC from all storage devices and add the SVMs only as opposed to the cluster. The slightly eye rolling thing is that when you add an SVM to the VSC it tells you that to get full functionnality you should add the cluster.

 

Based on the conversation with the support engineer they seem to agree that this is less than optimum and it has been brought up to engineering.

 

While I am not overly impressed by the solution, it is important to say that the support experience was great

 

Re: SnapCenter 1.1 NFS Volume Backup with VSC Fails on New-NcSnapshotMulti

this error are bacause Cluster Server is attached with VSC and Snap Center does not need C-Server. it works with Storage Virtual Machine(SVM). Just do a registeration of VSC from Snap Center and problem will solve. 

 

 

thanks