Subscribe
Accepted Solution

SnapCreator 3.5 Domino# Failed to take a snap

[ Edited ]

Dear all,

I've installed SC 3.5 on a Windows 2008 R2 x64 machine. Also I've installed SnapDrive following the compatibility matrix.

I've created a basic configuration following TR-4009.

Everything seems OK, however when I'm going to take a snapshot a message about a missing dll library appears on the screen (see it bellow).

I suppose this is a DLL provided by SnapCreator so I've tried to download another version of SC, but I didn't found the missing dll on it.

Could you please help me to solve this issue?

Thanks.

[Mon May 14 12:21:16 2012] INFO: Logfile timestamp: 20120514122116

########## Parsing Environment Parameters ##########

########## PRE APPLICATION QUIESCE COMMANDS ##########

[Mon May 14 12:21:16 2012] INFO: No commands defined

########## PRE APPLICATION QUIESCE COMMANDS FINISHED SUCCESSFULLY ##########

########## Application quiesce ##########

[Mon May 14 12:21:16 2012] [127.0.0.1:9090(3.5.0.1)] ERROR: [agt-00013] ERROR: [ltd-00009] Domino plugin couldn't be loaded. Reasons could be 1) Domino plugin is not supported on this platform.

        2)Prerequisites for domino plugin to run are not satisfied. Please check documentation(domino plugin setup).

Trace:Can't load 'auto/dominocore/dominocore.dll' for module dominocore: load_file:No se puede encontrar el módulo especificado at /<C:\Program Files\Netapp\NetApp_Snap_Creator_Framework\scAgent3.5.0\snapcreator.exe>DynaLoader.pm line 219.

at /<C:\Program Files\Netapp\NetApp_Snap_Creator_Framework\scAgent3.5.0\snapcreator.exe>dominocore.pm line 11

[Mon May 14 12:21:18 2012] ERROR: ERROR: [ltd-00009] Domino plugin couldn't be loaded. Reasons could be 1) Domino plugin is not supported on this platform.

        2)Prerequisites for domino plugin to run are not satisfied. Please check documentation(domino plugin setup).

Trace:Can't load 'auto/dominocore/dominocore.dll' for module dominocore: load_file:No se puede encontrar el módulo especificado at /<C:\Program Files\Netapp\NetApp_Snap_Creator_Framework\scAgent3.5.0\snapcreator.exe>DynaLoader.pm line 219.

at /<C:\Program Files\Netapp\NetApp_Snap_Creator_Framework\scAgent3.5.0\snapcreator.exe>dominocore.pm line 11

[Mon May 14 12:21:18 2012] [127.0.0.1:9090(3.5.0.1)] ERROR: [scf-00053] Application quiesce for plugin domino failed with exit code 1, Exiting!

########## Application unquiesce ##########

[Mon May 14 12:21:18 2012] [127.0.0.1:9090(3.5.0.1)] ERROR: [agt-00013] ERROR: [ltd-00009] Domino plugin couldn't be loaded. Reasons could be 1) Domino plugin is not supported on this platform.

        2)Prerequisites for domino plugin to run are not satisfied. Please check documentation(domino plugin setup).

Trace:Can't load 'auto/dominocore/dominocore.dll' for module dominocore: load_file:No se puede encontrar el módulo especificado at /<C:\Program Files\Netapp\NetApp_Snap_Creator_Framework\scAgent3.5.0\snapcreator.exe>DynaLoader.pm line 219.

at /<C:\Program Files\Netapp\NetApp_Snap_Creator_Framework\scAgent3.5.0\snapcreator.exe>dominocore.pm line 11

[Mon May 14 12:21:20 2012] ERROR: ERROR: [ltd-00009] Domino plugin couldn't be loaded. Reasons could be 1) Domino plugin is not supported on this platform.

        2)Prerequisites for domino plugin to run are not satisfied. Please check documentation(domino plugin setup).

Trace:Can't load 'auto/dominocore/dominocore.dll' for module dominocore: load_file:No se puede encontrar el módulo especificado at /<C:\Program Files\Netapp\NetApp_Snap_Creator_Framework\scAgent3.5.0\snapcreator.exe>DynaLoader.pm line 219.

at /<C:\Program Files\Netapp\NetApp_Snap_Creator_Framework\scAgent3.5.0\snapcreator.exe>dominocore.pm line 11

[Mon May 14 12:21:22 2012] ERROR: [scf-00054] Application unquiesce for plugin domino failed with exit code 1, Exiting!

########## PRE EXIT COMMANDS ##########

[Mon May 14 12:21:22 2012] INFO: No commands defined

########## PRE EXIT COMMANDS FINISHED SUCCESSFULLY ##########

Re: SnapCreator 3.5 Domino# Failed to take a snap

Hi Jose,

   Which snapcreator installer have you downloaded? is it 64 bit or 32 bit. It should be same bit level as the domino. Have you added domino dll's in the PATH variable? Are you running snapcreator as a service?

Regards,

Justin Skariah

Re: SnapCreator 3.5 Domino# Failed to take a snap

Hi Justints, Hi all;

Thanks for your quick answer.

SnapCreator is 64bit version as well as Domino and Windows 2008 R2.

I've added the domino dlls to path variable and rebooted the server to make sure the change is loaded.

SnapCreator 3.5 is not working fine as a service, I've created an scheduled task that runs SCAgent and SCServer when Windows boots-up.

I've just one server for Domino and for snapcreator, so I can't split Agent and Server.

Still doesn't work, but now the behaviour and error log is different:

[Mon May 14 20:51:16 2012] DEBUG: GMT - Mon May 14 18:51:16 2012

[Mon May 14 20:51:16 2012] DEBUG: Version: NetApp Snap Creator Framework 3.5.0

[Mon May 14 20:51:16 2012] DEBUG: Profile: domino

[Mon May 14 20:51:16 2012] DEBUG: Config Type: STANDARD

[Mon May 14 20:51:16 2012] DEBUG: Action: snap

[Mon May 14 20:51:16 2012] DEBUG: Application Plugin: domino

[Mon May 14 20:51:16 2012] DEBUG: File System Plugin: null

[Mon May 14 20:51:16 2012] DEBUG: Policy: daily

[Mon May 14 20:51:16 2012] DEBUG: Snapshot Name: daily_bak-daily_20120514205116

[Mon May 14 20:51:16 2012] INFO: Logfile timestamp: 20120514205116

########## Parsing Environment Parameters ##########

[Mon May 14 20:51:16 2012] DEBUG: Parsing VOLUMES - controller: valcentlun volume: NOTES

[Mon May 14 20:51:16 2012] DEBUG: Parsing NTAP_USERS - controller: VALCENTREP1 user: sc_user

[Mon May 14 20:51:16 2012] DEBUG: Parsing NTAP_USERS - controller: valcentlun user: sc_user

[Mon May 14 20:51:16 2012] DEBUG: Parsing NTAP_SNAPSHOT_RETENTIONS - policy: daily retention: 31

[Mon May 14 20:51:16 2012] DEBUG: Parsing SNAPMIRROR_VOLUMES - controller: valcentlun sm volume: NOTES

########## PRE APPLICATION QUIESCE COMMANDS ##########

[Mon May 14 20:51:16 2012] INFO: No commands defined

########## PRE APPLICATION QUIESCE COMMANDS FINISHED SUCCESSFULLY ##########

########## Application quiesce ##########

[Mon May 14 20:51:17 2012] [127.0.0.1:9090(3.5.0.1)] INFO: Quiescing databases

[Mon May 14 20:51:17 2012] [127.0.0.1:9090(3.5.0.1)] DEBUG: Calling dominocore::quiesce with arguments(D:\Lotus\Domino,D:\Lotus\Domino\data,I:\Changeinfo,0 )

[Mon May 14 20:51:20 2012] [127.0.0.1:9090(3.5.0.1)] TRACE:

Error initializing Notes. Error Code:421

ERROR_CODE:1

[Mon May 14 20:51:20 2012] [127.0.0.1:9090(3.5.0.1)] INFO: No Errors encountered while opening DBs.

[Mon May 14 20:51:20 2012] [127.0.0.1:9090(3.5.0.1)] ERROR: [ltd-00002] Quiescing databases finished with errors

[Mon May 14 20:51:20 2012] [127.0.0.1:9090(3.5.0.1)] ERROR: [scf-00053] Application quiesce for plugin domino failed with exit code 1, Exiting!

########## Application unquiesce ##########

[Mon May 14 20:51:23 2012] ERROR: 500 Status read failed: Se ha forzado la interrupción de una conexión existente por el host remoto. at /<C:\Program Files\Netapp\NetApp_Snap_Creator_Framework\scServer3.5.0\snapcreator.exe>SnapCreator/Agent/Remote.pm line 474

[Mon May 14 20:51:23 2012] ERROR: [scf-00054] Application unquiesce for plugin domino failed with exit code 1, Exiting!

########## PRE EXIT COMMANDS ##########

[Mon May 14 20:51:23 2012] INFO: No commands defined

########## PRE EXIT COMMANDS FINISHED SUCCESSFULLY ##########

[Mon May 14 20:51:24 2012] DEBUG: Exiting with error code - 2

Re: SnapCreator 3.5 Domino# Failed to take a snap

Error 421 is "NOTES.INI not found in path". In your config you have set DOMINO_INI_PATH=D:\Lotus\Domino, but it should actually include the notes.ini in the path. so it should be

DOMINO_INI_PATH=D:\Lotus\Domino\notes.ini , just check if notes.ini file exist at that path

DOMINO_INI_PATH - Path to notes.ini file (include notes.ini in path)

Hope this helps.

Regards,

Justin Skariah

Re: SnapCreator 3.5 Domino# Failed to take a snap

Hi,

Thank you so much justints.

Once I've set path to include notes.ini, it seems it will work. However after around 20-30 minutes SC trying to quiesce Domino, it fails.

This is de debug log of the job:

[Tue May 15 12:20:01 2012] DEBUG: GMT - Tue May 15 10:20:01 2012

[Tue May 15 12:20:01 2012] DEBUG: Version: NetApp Snap Creator Framework 3.5.0

[Tue May 15 12:20:01 2012] DEBUG: Profile: domino

[Tue May 15 12:20:01 2012] DEBUG: Config Type: STANDARD

[Tue May 15 12:20:01 2012] DEBUG: Action: snap

[Tue May 15 12:20:01 2012] DEBUG: Application Plugin: domino

[Tue May 15 12:20:01 2012] DEBUG: File System Plugin: null

[Tue May 15 12:20:01 2012] DEBUG: Policy: daily

[Tue May 15 12:20:01 2012] DEBUG: Snapshot Name: daily_bak-daily_20120515122000

[Tue May 15 12:20:01 2012] INFO: Logfile timestamp: 20120515122000

########## Parsing Environment Parameters ##########

[Tue May 15 12:20:01 2012] DEBUG: Parsing VOLUMES - controller: valcentlun volume: NOTES

[Tue May 15 12:20:01 2012] DEBUG: Parsing NTAP_USERS - controller: VALCENTREP1 user: sc_user

[Tue May 15 12:20:01 2012] DEBUG: Parsing NTAP_USERS - controller: valcentlun user: sc_user

[Tue May 15 12:20:01 2012] DEBUG: Parsing NTAP_SNAPSHOT_RETENTIONS - policy: daily retention: 31

[Tue May 15 12:20:01 2012] DEBUG: Parsing SNAPMIRROR_VOLUMES - controller: valcentlun sm volume: NOTES

########## PRE APPLICATION QUIESCE COMMANDS ##########

[Tue May 15 12:20:01 2012] INFO: No commands defined

########## PRE APPLICATION QUIESCE COMMANDS FINISHED SUCCESSFULLY ##########

########## Application quiesce ##########

[Tue May 15 12:35:01 2012] ERROR: No valid response

[Tue May 15 12:35:01 2012] ERROR: [scf-00053] Application quiesce for plugin domino failed with exit code 1, Exiting!

########## Application unquiesce ##########

[Tue May 15 12:50:01 2012] ERROR: No valid response

[Tue May 15 12:50:01 2012] ERROR: [scf-00054] Application unquiesce for plugin domino failed with exit code 1, Exiting!

########## PRE EXIT COMMANDS ##########

[Tue May 15 12:50:01 2012] INFO: No commands defined

########## PRE EXIT COMMANDS FINISHED SUCCESSFULLY ##########

I don't know where I should look now, it seems SC can't quiesce Domino but I don't know why or how to solve it.

Thanks for your help.

Re: SnapCreator 3.5 Domino# Failed to take a snap

Seems like Domino is taking really long / hanging for whatever reason, SC doesnt really have control over this. The SC Agent does have a timeout SC_AGENT_TIMEOUT it is usually set to 900 which is 15 minutes. You may want to set this higher if it is timing out.

The other option is you can bypass agent and install SC Server directly on the Domino host, this may be a simpler configuration. If no agent is used SC will wait forever. We have seen in some environments that the quiesce process can take up to 30 mins.

Regards,

Keith

Re: SnapCreator 3.5 Domino# Failed to take a snap

Jose,

Can you copy/paste the section of the config file that contains the Domino parameters?

I'd just like to take a look and see your settings.

If agent logging is enabled can you check the logs on the agent and see what information they contain?

Thanks!

John

Re: SnapCreator 3.5 Domino# Failed to take a snap

Hi, thanks for put me on the lead.

Finally the problem was SCAgent is not running properly, I mean according to services.msc it was running, but actually it wasn't.

I've defined on agent.conf the parameter "commands: *", restarted SCAgent and now it's working. I've got my first Domino snapshot.

Thank you so much all of you for helping me.

Re: SnapCreator 3.5 Domino# Failed to take a snap

Glad to hear Jose and your welcome!

Happy Snap Creating!

Keith

Re: SnapCreator 3.5 Domino# Failed to take a snap

Hello keith

I have the same initial problem : domino plugin does not want to load

domino server on win2008 R2 64bit

snapcreator 3.6.0 64bit agent installed

PATH has been changed to include domino binaries but win server not restarted

PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32

\WindowsPowerShell\v1.0\;C:\Lotus\Domino

Server config file :

DOMINO_DATA_PATH=E:\notesdata

DOMINO_INI_PATH=C:\Lotus\Domino\notes.ini

DOMINO_CHANGE_INFO_PATH=F:\SnapCreatorLogs

DOMINO_DATABASE_TYPE=0

LOTUS=C:\Lotus

Notes_ExecDirectory=C:\Lotus\Domino

DOMINO_RESTORE_DATA_PATH=F:\SnapCreatorRestore

scAgent trace on domino's server:

[Wed Jul  3 21:43:50 2013] ERROR: [agt-00013] ERROR: [ltd-00009] Domino plugin couldn't be loaded. Reasons could be 1) Domino plugin is not supported on this platform.

        2)Prerequisites for domino plugin to run are not satisfied. Please check documentation(domino plugin setup).

Trace:Can't load 'auto/dominocore/dominocore.dll' for module dominocore: load_file:Le module spécifié est introuvable at /<C:\Program Files\NetApp\NetApp_Snap_Creator_Framework\scAgent3.6.0\snapcreator.exe>DynaLoader.pm line 219.

at /<C:\Program Files\NetApp\NetApp_Snap_Creator_Framework\scAgent3.6.0\snapcreator.exe>dominocore.pm line 11

[Wed Jul  3 21:43:50 2013] INFO: Starting watchdog with [-1472], forced unquiesce timeout [300] second(s)

[Wed Jul  3 21:43:50 2013] ERROR: [agt-00013] ERROR: [ltd-00009] Domino plugin couldn't be loaded. Reasons could be 1) Domino plugin is not supported on this platform.

        2)Prerequisites for domino plugin to run are not satisfied. Please check documentation(domino plugin setup).

Trace:Can't load 'auto/dominocore/dominocore.dll' for module dominocore: load_file:Le module spécifié est introuvable at /<C:\Program Files\NetApp\NetApp_Snap_Creator_Framework\scAgent3.6.0\snapcreator.exe>DynaLoader.pm line 219.

at /<C:\Program Files\NetApp\NetApp_Snap_Creator_Framework\scAgent3.6.0\snapcreator.exe>dominocore.pm line 11

--------------------------------------------------------------------

[Wed Jul  3 21:43:49 2013] DEBUG: Reloading configuration from C:\Program Files\NetApp\NetApp_Snap_Creator_Framework\scAgent3.6.0\config\agent.conf

[Wed Jul  3 21:43:49 2013] DEBUG: Reloading configuration finished with

exit code: [0]

stdout: []

stderr: []

[Wed Jul  3 21:43:49 2013] DEBUG: 172.30.0.18 / srvmgtnetapp02.xxxx.net is allowed to send requests

[Wed Jul  3 21:43:49 2013] INFO: Authorized request from [scServer@*]

[Wed Jul  3 21:43:50 2013] INFO: Authorized request from [scServer@*]