Subscribe
Accepted Solution

SnapCreator 3.6 Server - Problem setting GUI port.

[ Edited ]

Having installed SnapCreator 3.6 (under Winsows2003) as per installation guide, I am trying to alter the GUI port to something other than the default (8080).

I am attempting this using the following command;

java -jar snapcreator.jar -gui_port 8888

This seems to work ok, and SnapCreator Server starts up, and Jetty uses port 8888.

However, if I then start the "SnapCreator Server" Service (created during the installation), it reverts to using port 8080.

Does anyone know if there is a way to get SnapCreator to 'remember' this setting - or how to tell the Windows Service for SnapCreator Server to use a different port?

Re: SnapCreator 3.6 Server - Problem setting GUI port.

Hi,

Yes you need to change this in register where service is registered.

It is under HKEY_LOCAL_MACHINE->SOFTWARE->Wow6432Node->Apache Software Foundation->Procrun 2.0->SnapCreatorServerService->Parameters->Start

Change to:

start

C:\Program Files (x86)\NetApp\NetApp_Snap_Creator_Framework/scServer3.6.0/gui

8888

Let us know if this helps?

Regards,

Keith

Re: SnapCreator 3.6 Server - Problem setting GUI port.

Perfect answer! - this has solved my problem.

Many thanks Keith for the speedy reply!