Subscribe
Accepted Solution

SnapCreator 3.6 not detecting SnapDrive on the host

[ Edited ]

My environment is AIX 6.1, DB2 9.7, SnapDrive for Unix 5.0P1, and SnapCreator 3.6 on FAS3240 running Ontap 8.0.2P3 - all storage is FCP luns - everything falls within the Interoperability Matrix configurations.   I can creates clones with no problem - database quiesce, snapshots, clones, unquiesce complete successfully.  However, going through the logs of the job I noticed that it does not detect SnapDrive being used on the host.  I am concerned about getting consistent snapshots of the database as they will populate all QA and Dev environments.  Any thoughts are appreciated.

Re: SnapCreator 3.6 not detecting SnapDrive on the host

Hello,

There are two ways to take snapshots in SnapCreator. Either you can use SnapCreator APIs or let SnapDrive to take the snapshot copies. SnapCreator has ability to take the consistency group snapshots too through the APIs. All you need to do is to set following variables in the configuration file.

  • NTAP_CONSISTENCY_GROUP_SNAPSHOT
  • NTAP_CONSISTENCY_GROUP_TIMEOUT

However instead of APIs if you want to let SnapDrive take the snapshots, you would require to set following variables in the configuration file.

  • SNAPDRIVE
  • SNAPDRIVE_DISCOVERY

Please see SnapCreator documentation for more details on these variables.

Hope this helps.

Thanks,

Himanshu

Re: SnapCreator 3.6 not detecting SnapDrive on the host

Resolved - snapdrived was incorrectly started in the init.rc causing it to stop.