Subscribe

SnapCreator 4.1.0 migration from 3.6.0 to 4.1.0

[ Edited ]

Hello,

I tried to migrate our SnapCreator from 3.6.0 to 4.1.0. Installation works, but the update of the GUI fails with this error:

java -jar snapcreator.jar -upgrade

Upgrade Started...

java.sql.SQLException: No suitable driver

        at java.sql.DriverManager.getConnection(DriverManager.java:387)

        at java.sql.DriverManager.getConnection(DriverManager.java:354)

        at com.netapp.snapcreator.server.db.DerbyEngine.getEmbeddedConnection(DerbyEngine.java:147)

        at com.netapp.snapcreator.server.db.DerbyEngine.upgrade(DerbyEngine.java:274)

        at com.netapp.snapcreator.server.SnapCreatorServer.upgrade(SnapCreatorServer.java:365)

        at com.netapp.snapcreator.server.SnapCreatorServer.main(SnapCreatorServer.java:75)

Upgrade Failed

Regards

V. Albrecht

Re: SnapCreator 4.1.0 migration from 3.6.0 to 4.1.0

Hi

Will you please let us know the the list of files present under

NetApp\Snap_Creator_Framework\scServer4.1.0\engine\lib

-Hari

Re: SnapCreator 4.1.0 migration from 3.6.0 to 4.1.0

Hi,

here is the list:

/usr/local/scServer4.1.0/engine/lib # ls -l

total 7072

-rwxr-xr-x 1 root root  559108 Jan 16 13:06 apache-nutch-1.5.1.jar

-rwxr-xr-x 1 root root   41123 Jan 16 13:06 commons-cli-1.2.jar

-rwxr-xr-x 1 root root   60686 Jan 16 13:06 commons-logging-1.1.1.jar

-rwxr-xr-x 1 root root 2831358 Jan 16 13:06 derby.jar

-rwxr-xr-x 1 root root  582765 Jan 16 13:06 derbyclient.jar

-rwxr-xr-x 1 root root  250911 Jan 16 13:06 derbynet.jar

-rwxr-xr-x 1 root root    7118 Jan 16 13:06 derbyrun.jar

-rwxr-xr-x 1 root root  213271 Jan 16 13:06 derbytools.jar

-rwxr-xr-x 1 root root  313898 Jan 16 13:06 dom4j-1.6.1.jar

-rwxr-xr-x 1 root root  245113 Jan 16 13:06 flyway-core-2.1.1.jar

-rwxr-xr-x 1 root root   21163 Jan 16 13:06 jetty-continuation-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root   60772 Jan 16 13:06 jetty-deploy-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root   96042 Jan 16 13:06 jetty-http-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root  104233 Jan 16 13:06 jetty-io-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root   89924 Jan 16 13:06 jetty-security-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root  354264 Jan 16 13:06 jetty-server-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root  102560 Jan 16 13:06 jetty-servlet-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root   95364 Jan 16 13:06 jetty-servlets-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root  287536 Jan 16 13:06 jetty-util-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root  109975 Jan 16 13:06 jetty-webapp-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root   39000 Jan 16 13:06 jetty-xml-8.1.12.v20130726.jar

-rwxr-xr-x 1 root root  391834 Jan 16 13:06 log4j-1.2.15.jar

-rwxr-xr-x 1 root root  200387 Jan 16 13:06 servlet-api-3.0.jar

-rwxr-xr-x 1 root root   17241 Jan 16 13:06 start.jar

-rwxr-xr-x 1 root root   34407 Jan 16 13:06 ws-commons-util-1.0.2.jar

We run Snapcrator Server on SLES 11

Re: SnapCreator 4.1.0 migration from 3.6.0 to 4.1.0

Hi I tried upgrade(3.6.0 to 4.1.0)  in SLES 11 , it was working for us :-

VM-SLES11-64-BUILD-196-207:/opt/scServer4.1.0/engine # cat /etc/SuSE-release

SUSE Linux Enterprise Server 11 (x86_64)

VERSION = 11

PATCHLEVEL = 0

VM-SLES11-64-BUILD-196-207:/opt/scServer4.1.0/engine # java -jar snapcreator.jar -upgrade

Upgrade Started...

Rows in sys.systables = 45

Current DB_VERSION = 3.6

Verifying environment...

Finished Verification.

Converting 3.6 Config Files to 4.1

Starting conversion ...

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/default/default.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/foo/foo.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/global.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/mnt_clone.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/Multiple_pre_post_cmds_quisce_and_unquisce_without_app_with_agent_while_backup.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/Multiple_pre_post_cmds_quisce_and_unquisce_without_app_with_server_while_backup.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/pre_post_cmds_quisce_and_unquisce_without_app_with_server_while_backup.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/POST_NTAP_DATA_TRANSFER_CMD01_without_application_with_agent.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/PRE_NTAP_CLONE_DELETE_with_vol_clone_with_Server.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/PRE_POST_RESTORE_CMD01_without_application_with_server.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/pre_post_cmds_quisce_and_unquisce_without_app_with_agent_while_backup.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/App_commands_without_plugins_with_backup_agent.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/PRE_POST_NTAP_CLONE_CREATE_with_vol_clone_with_agent.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/App_commands_without_plugins_with_backup_with_server.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/Mount_Unmount_commands_without_plugins_with_backup_server.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/PRE_POST_RESTORE_CMD01_without_application_with_agent.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/PRE_POST_NTAP_CLONE_CREATE_with_vol_clone_with_Server.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/POST_NTAP_DATA_TRANSFER_CMD01_without_application_with_server.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/PRE_NTAP_CLONE_DELETE_with_vol_clone_with_Agent.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/pre_post_NTAP_commands_without_plugins_with_backup_server.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/pre_post_NTAP_commands_without_plugins_with_backup_Agent.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mnt_clone/Mount_Unmount_commands_without_plugins_with_backup_agent.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mysql/mysql_working.conf disabled, skipping!

[Thu Feb  6 19:01:46 2014] INFO: Password protection in config configs/mysql/mysql_error.conf disabled, skipping!

Finished Conversion of 3.6 Config Files.

Running: com.netapp.snapcreator.server.db.flyway.migration.V3_6_0_01__SCDB_Initial_Version

Running: com.netapp.snapcreator.server.db.flyway.migration.V3_6_0_02__SCDB_RBAC_Initialization

Running: com.netapp.snapcreator.server.db.flyway.migration.V4_0_0_01__SCDB_Initial_Version

Running: com.netapp.snapcreator.server.db.flyway.migration.V4_0_0_02__SCDB_RBAC_UPDATES

Upgrade Succeeded

Is it possible to share your SLES machine snapcreator database localted in path /scServer4.1.0/engine ?

Re: SnapCreator 4.1.0 migration from 3.6.0 to 4.1.0

What is your Java version?
Could you please upgrade to Java version 7.0 and try?

Re: SnapCreator 4.1.0 migration from 3.6.0 to 4.1.0

We have tried with Java 1.7.0..upgrade worked from 3.6.0 to 4.1.0

VM-SLES11-64-BUILD-196-207:/opt/scServer4.1.0/engine # java -version

java version "1.7.0_51"

Java(TM) SE Runtime Environment (build 1.7.0_51-b13)

Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

VM-SLES11-64-BUILD-196-207:/opt/scServer4.1.0/engine # cat /etc/SuSE-release

SUSE Linux Enterprise Server 11 (x86_64)

VERSION = 11

PATCHLEVEL = 0

VM-SLES11-64-BUILD-196-207:/opt/scServer4.1.0/engine # java -jar snapcreator.jar -upgrade

Upgrade Started...

Rows in sys.systables = 45

Current DB_VERSION = 3.6

Verifying environment...

Finished Verification.

Converting 3.6 Config Files to 4.1

Starting conversion ...

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/default/default.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/foo/foo.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/global.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/mnt_clone.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/Multiple_pre_post_cmds_quisce_and_unquisce_without_app_with_agent_while_backup.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/Multiple_pre_post_cmds_quisce_and_unquisce_without_app_with_server_while_backup.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/pre_post_cmds_quisce_and_unquisce_without_app_with_server_while_backup.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/POST_NTAP_DATA_TRANSFER_CMD01_without_application_with_agent.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/PRE_NTAP_CLONE_DELETE_with_vol_clone_with_Server.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/PRE_POST_RESTORE_CMD01_without_application_with_server.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/pre_post_cmds_quisce_and_unquisce_without_app_with_agent_while_backup.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/App_commands_without_plugins_with_backup_agent.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/PRE_POST_NTAP_CLONE_CREATE_with_vol_clone_with_agent.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/App_commands_without_plugins_with_backup_with_server.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/Mount_Unmount_commands_without_plugins_with_backup_server.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/PRE_POST_RESTORE_CMD01_without_application_with_agent.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/PRE_POST_NTAP_CLONE_CREATE_with_vol_clone_with_Server.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/POST_NTAP_DATA_TRANSFER_CMD01_without_application_with_server.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/PRE_NTAP_CLONE_DELETE_with_vol_clone_with_Agent.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/pre_post_NTAP_commands_without_plugins_with_backup_server.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/pre_post_NTAP_commands_without_plugins_with_backup_Agent.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mnt_clone/Mount_Unmount_commands_without_plugins_with_backup_agent.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mysql/mysql_working.conf disabled, skipping!

[Fri Feb  7 00:38:55 2014] INFO: Password protection in config configs/mysql/mysql_error.conf disabled, skipping!

Finished Conversion of 3.6 Config Files.

Running: com.netapp.snapcreator.server.db.flyway.migration.V3_6_0_01__SCDB_Initial_Version

Running: com.netapp.snapcreator.server.db.flyway.migration.V3_6_0_02__SCDB_RBAC_Initialization

Running: com.netapp.snapcreator.server.db.flyway.migration.V4_0_0_01__SCDB_Initial_Version

Running: com.netapp.snapcreator.server.db.flyway.migration.V4_0_0_02__SCDB_RBAC_UPDATES

Upgrade Succeeded

Re: SnapCreator 4.1.0 migration from 3.6.0 to 4.1.0

Hello,

ok, now the upgrade works, but the snapcreator dosen´t work ☹

I start this command:

/usr/local/scServer4.1.0 # ./snapcreator --server   --port 8443 --user admin –passwd ****** --profile list --verbose

Then only this line appears on the screen:

                    1. NetApp Snap Creator Framework 4.1.0 Configurations ##########

and then nothing….

In the logs are no messages….

Mit freundlichen Grüßen

Volker Albrecht

Re: SnapCreator 4.1.0 migration from 3.6.0 to 4.1.0

Volker,

Did you copy over your profiles and configuration files?

Snap Creator is running and reporting back that you don't have any profiles to list.

If I run the same command in my environment I get a list of all of the profiles and configuration files.

Be sure that you copied the profile directory into:

/path/to/scServer4.1.0/engine/configs

3.6 did not have the "engine" subdirectory and the configs were just under the scServer directory.  If you put them there then Snap Creator will not know about them.

Hope this helps!

John

Re: SnapCreator 4.1.0 migration from 3.6.0 to 4.1.0

Hello,

yes, I´ve copied the config files in the directory configs in this path  /usr/local/scServer4.1.0/engine. From the GUI, I can see all the files, but from CLI the command dosen´t  came back.

Mit freundlichen Grüßen

Volker Albrecht

Re: SnapCreator 4.1.0 migration from 3.6.0 to 4.1.0

Hi,

i can see the profile list in CLI

VM-SLES11-64-BUILD-196-207:/opt/scServer4.1.0 # ./snapcreator -version

NetApp Snap Creator Framework 4.1.0

VM-SLES11-64-BUILD-196-207:/opt/scServer4.1.0 # ./snapcreator --server localhost --port 8450 --user sctest --passwd sctest --profile list --verbose

########## NetApp Snap Creator Framework 4.1.0 Configurations ##########

default

     default (profile)

mnt_clone

     Multiple_pre_post_cmds_quisce_and_unquisce_without_app_with_server_while_backup (config)

     mnt_clone (profile)

     pre_post_NTAP_commands_without_plugins_with_backup_server (config)

     PRE_POST_RESTORE_CMD01_without_application_with_server (config)

     PRE_POST_RESTORE_CMD01_without_application_with_agent (config)

     PRE_NTAP_CLONE_DELETE_with_vol_clone_with_Server (config)

     App_commands_without_plugins_with_backup_with_server (config)

     Mount_Unmount_commands_without_plugins_with_backup_server (config)

     POST_NTAP_DATA_TRANSFER_CMD01_without_application_with_agent (config)

     PRE_POST_NTAP_CLONE_CREATE_with_vol_clone_with_agent (config)

     POST_NTAP_DATA_TRANSFER_CMD01_without_application_with_server (config)

     pre_post_cmds_quisce_and_unquisce_without_app_with_server_while_backup (config)

     PRE_NTAP_CLONE_DELETE_with_vol_clone_with_Agent (config)

     pre_post_NTAP_commands_without_plugins_with_backup_Agent (config)

     App_commands_without_plugins_with_backup_agent (config)

     Multiple_pre_post_cmds_quisce_and_unquisce_without_app_with_agent_while_backup (config)

     Mount_Unmount_commands_without_plugins_with_backup_agent (config)

     PRE_POST_NTAP_CLONE_CREATE_with_vol_clone_with_Server (config)

     pre_post_cmds_quisce_and_unquisce_without_app_with_agent_while_backup (config)

foo

     foo (profile)

mysql

     mysql_error (config)

     mysql_working (config)

Looked into your command line inputs /usr/local/scServer4.1.0 # ./snapcreator --server   --port 8443 --user admin –passwd ****** --profile list --verbose

The server parameter input is missing in command line...Please input the "--server" IP and try.