Subscribe
Accepted Solution

SnapCreator 4.1.0c - snapshot for MAXDB failed

[ Edited ]

Hello guys,

I have problem take snapshot for MAXDB. I´ve obtained error which can you see in attachment.

any idea what can be wrong?

Thank you

BR. Jakub

Re: SnapCreator 4.1.0c - snapshot for MAXDB failed

Hello Jakub,

What user account is used to run the Snap Creator Agent?

As the same user account above, are you able to run the below command from the shell?

     /sapdb/clients/LM1/bin/dbmcli -d LM1 -u control,xxxxxxxx  db_state

Do you have % in your password? If so, please change the password without % and try again.

The % may need to be escaped in your shell environment with a \

Please let me know.


Thanks

Siva Ramanathan

Re: SnapCreator 4.1.0c - snapshot for MAXDB failed

Hello Siva,

Snap Creator Agent is running under root user.

Output from command from the shell:

/sapdb/clients/LM1/bin/dbmcli -d LM1 -u control,XXXXX db_state

OK

State

ONLINE

Password doesn´t contain "%".

Any next tips?

Thank you

Jakub Babilon

Re: SnapCreator 4.1.0c - snapshot for MAXDB failed

Please upload a scdump (obtained by running Action->scdump from the GUI).

You may email the output to sivar at netapp.com

I will review your config file and associated logs and get back to you.

Also, please try with a DBADMIN user.

In my setup, I have dbm user defined as below.

#  dbmcli -d MaxDB1 -u dbm,dbm user_get dbm

OK

SERVERRIGHTS=UserMgm,InstallMgm,SystemCmd,DBFileRead,AccessUtility,Recovery,Backup,ParamFull,ParamCheckWrite,ParamRead,AccessSQL,ExecLoad,LoadSysTab,DBStop,DBStart,DBInfoRead,SharedMemoryMgm,SchedulerMgm,Scheduling,EvtDispMgm,EvtDisp

GUIRIGHTS=

SECONDPASSWORD=NO

DISABLED=NO

COMMENT=

USERTYPE=DBM

EXTERNAL_IDS=

Re: SnapCreator 4.1.0c - snapshot for MAXDB failed

Hello Siva,

email has been send with scDump.

[root@tsbp01sap10 configs]# /sapdb/clients/LM1/bin/dbmcli -d LM1 -u control,XXXXX user_get control

OK

SERVERRIGHTS=UserMgm,InstallMgm,SystemCmd,DBFileRead,AccessUtility,Recovery,Backup,ParamFull,ParamCheckWrite,ParamRead,AccessSQL,ExecLoad,LoadSysTab,DBStop,DBStart,DBInfoRead,SharedMemoryMgm,SchedulerMgm,Scheduling,EvtDispMgm,EvtDisp

GUIRIGHTS=

SECONDPASSWORD=NO

DISABLED=NO

COMMENT=

USERTYPE=DBM

EXTERNAL_IDS=

Thank you

Jakub Babilon

Re: SnapCreator 4.1.0c - snapshot for MAXDB failed

I have found what caused this issue probably. Wrong password Hash in config file.

I have the same problem on other one system when I have started testing new official release SC 4.1.0.

I tried to use command: snapcreator –pwdConvert /install_path/engine/config.

Command completed successfully however when I compated hash from config file and output from commad snapcreator –pwdCrypt then I saw difference hash.

So I tried to change it manually and it´s working OK now.

It seems that I'll need to change all password hashes in all configuration files manually.

Thank you Siva for help

Email from Siva:

Jakub,

pwdConvert is only to be used in scenarios where 3.6 to 4.0 upgrade happens.

pwdCrypt is the command you need to use in 4.1