Subscribe

SnapCreator POST_NTAP command failure?

[ Edited ]

SnapCreator server is currenlty configured to run from a designated management host accessing the Oracle servers via the agent on remote host.  I have configured the SC Server to run a POST_NTAP command (intended to do a log switch on the archive logs).  The main part of the config executes without any errors (i.e. accesses the DB server, puts DB into hot-backup mode, updates snapmirror, etc..).  When it gets to the section for the POST command I get the following error (before it errored indicating the agent.conf was empty, I added a * ):

########## POST NETAPP COMMANDS ##########

[Fri Jun  3 11:26:49 2011] INFO: Running post netapp command POST_NTAP_CMD01 [/usr/local/netapp/NTAPscreator/scServer3.3.0/snapcreator --profile SBW_DB1 --action snap --policy hourly --config SBW_DB_ARCH --verbose]

[Fri Jun  3 11:26:39 2011] [leopard:9090(3.3.0.1)] ERROR: Command [/usr/local/netapp/NTAPscreator/scServer3.3.0/snapcreator --profile SBW_DB1 --action snap --policy hourly --config SBW_DB_ARCH --verbose] failed with return code [-1] and message [ ]

[Fri Jun  3 11:26:49 2011] ERROR: Running post netapp command [/usr/local/netapp/NTAPscreator/scServer3.3.0/snapcreator --profile SBW_DB1 --action snap --policy hourly --config SBW_DB_ARCH --verbose] failed with exit code [-1] and message  [ ]

########## POST NETAPP COMMANDS FINISHED WITH FAILURES ##########

This is the entry in the config file:

#####################

### Post Commands ###

#####################

POST_APP_QUIESCE_CMD01=

POST_NTAP_CMD01=/usr/local/netapp/NTAPscreator/scServer3.3.0/snapcreator --profile SBW_DB1 --action snap --policy hourly --config SBW_DB_ARCH --verbose

POST_NTAP_DATA_TRANSFER_CMD01=

POST_APP_UNQUIESCE_CMD01=

POST_RESTORE_CMD01=

POST_CLONE_CREATE_CMD01=

Any ideas?

Thanks -

SnapCreator POST_NTAP command failure?

What happens when you run the ntap_post_cmd01 by hand from command prompt?

Regards,

Keith

SnapCreator POST_NTAP command failure?

When executed from the command line, no problems, no errors.  It is able to access the DB server, perform the log switch, update the snapmirror.

SnapCreator POST_NTAP command failure?

It looks like SC is running the post_ntap_cmd01 on leopard where agent is and it isn't permitted. If you have agent configured all the Pre/post stuff gets executed there so that is probably the issue.

You may want to just run db and arch configs separately since I don't think what you are trying to do w/agent will work. In order to run Pre/post cmds on agent you need to allow them, on agent is an agent.conf file under /config and you can add allowed cmds there. However this would mean setting up scServer there to run this config.

As mentioned I think only workaround is to run configs separately, first db then arch, you could create wrapper to do this or just space them out in scheduler or cron.

I think as feature request we need ability to either use agent or not if it is configured for Pre/post cmds.

Regards,

Keith

SnapCreator POST_NTAP command failure?

See my above post if you look you will see SC is trying to execute post cmd on agent, unfortunately agent is all or none so if configured everything goes there.

Keith

SnapCreator POST_NTAP command failure?

Thanks,

That explains why it is not working, sort of defeats the purpose of a Client --> Server relationship, if you have to install the Server on the Client to execute the same command you can execute via the server from the command line... That would be a great feature request to be able to coordinate two operations that have dependancies from the Server that require unique config files.

SnapCreator POST_NTAP command failure?

Agreed, I think we need to provide mechanism to define if a set of pre/post cmds should execute on agent or server so its more granular.

Keith