Subscribe

SnapCreator - Snapshot failed after upgrading to SC 4.1.0c

[ Edited ]

Hi guys,

I have problem to perform successfully snapshot after upgrading from SC 4.0p1 to SC 4.1.0c (community release). Upgrading has been done according to

https://snapcreator.netapp.com/sites/default/files/releases/stable/4.1.0c/Snap_Creator_Community_Release_4.1.0c-Installation_Guide.pdf


Error message:

########## Application Quiesce ##########

[Mon Nov 25 21:57:13 2013] INFO: Application Quiesce for plugin : oracle

[Mon Nov 25 21:57:17 2013] ERROR: SCF-00037: Application quiesce for plug-in [oracle] failed with error [org.codehaus.jackson.map.exc.UnrecognizedPropertyException: Unrecognized f com.netapp.snapcreator.agent.nextgen.common.result.Result), not marked as ignorable

at [Source: sun.net.www.protocol.http.HttpURLConnection$HttpInputStream@303459ed; line: 1, column: 290] (through reference chain: com.netapp.snapcreator.agent.nextgen.common.resu] and exit code [-1], Exiting!

[Mon Nov 25 21:57:17 2013] ERROR: Task: quiesce with config:oracle@er1 failed

########## Application Unquiesce ##########

[Mon Nov 25 21:57:17 2013] INFO: Application Unquiesce for plugin: oracle

[Mon Nov 25 21:57:22 2013] ERROR: SCF-00032: Application unquiesce failed due to application error. To ignore application errors and proceed with backup you can set APP_IGNORE_ERR

[Mon Nov 25 21:57:23 2013] ERROR: Task: unquiesce with config:oracle@er1 failed

[Mon Nov 25 21:57:23 2013] ERROR: Snap Creator Community Release 4.1.0c CLI action backup failed

What can be wrong? Could you somebody help me?

Thank you

Re: SnapCreator - Snapshot failed after upgrading to SC 4.1.0c

Jakub -

Did you upgrade the Snap Creator Agent to SC 4.1 as well as the Snap Creator Server?

We would need a little bit more information to troubleshoot this issue.

Can you provide an scdump? 

If you don't want to post you can email it to spinks at netapp dot com.

FYI - I'm going to delete the other posts as they seem to be duplicates.

Thanks,

John

Re: SnapCreator - Snapshot failed after upgrading to SC 4.1.0c

Hello John,

yes please, remove duplicate posts. My bad, I´m sorry!

scAgent has been upgraded to SC4.1.0c too.

scdump has been sent to your email address.

Thanks,

Jakub

Re: SnapCreator - Snapshot failed after upgrading to SC 4.1.0c

No problem - I just wanted you to know that I was deleting them.

Thanks for confirmation on the upgrade.  I just got the scdump.  I'll take a look and get back to you soon.

Thanks,

John

Re: SnapCreator - Snapshot failed after upgrading to SC 4.1.0c

Since Jakub and I took this conversation to email, I wanted to update the thread in case anyone else encounters this issue.

Jakub provided us with a scdump as well as the agent.log files, which are located in /install/path/scAgent4.1.0c/logs/agent.log

Since I had not seen this message before, one of the SC Developers was kind enough to review the logs.

He noticed the following in the agent.log file:

[2013-11-25T12:25:27,572+0200] DEBUG [Thread-18] com.netapp.snapcreator.agent.nextgen.plugin.legacyservice.StreamLogger - run() - type=stderr, wid=3, p=oracle - /bin/sh: plugins/wrapper/wrapper: Permission denied

Can you please verify with them that

/install/path/scAgent4.1.0c/plugins/wrapper/wrapper

has execute permission on the user they are trying to run SC? If changing the permission on that files does help, please check if they can maybe re-test with +rwx on all files for the current user?

The execute permission was indeed missing and after updating this the backup was able to run successfully.

Thanks,

John

Re: SnapCreator - Snapshot failed after upgrading to SC 4.1.0c

Setting chmod +x on plugins/wrapper/wrapper for the user executing scAgent should solve the issue.