Subscribe

SnapCreator Upgrade from 3.3 to 3.4

[ Edited ]

To upgrade to v3.4 the guide indicates to use the following variables in the exisint 3.3 configs:

  • CONFIG_TYPE -PLUGIN|STANDARD
  • USE_PROXY - (Y|N).
  • NTAP_CONSISTENCY_GROUP_WAFL_SYNC - (Y|N)
  • NTAP_SNAPSHOT_RESTORE_AUTO_DETECT - (Y|N
  • MOUNT_CMD<##>
  • UMOUNT_CMD<##> APP_DEFINED_CLONE -(Y|N)

Are these the only variables needed?  Seems like there are many more variables in 3.4...

For the upgrade, this is the procedure I was going to follow:

1. Stop 3.3 GUI on scServer

2. Install new 3.4 Snap Creator

3. Copy the unique DB config files from 3.3 to the 3.4 config directory

4. Add variables as indicated above

5. Update scripts to point to new 3.4 directory

6. Start the java GUI from the 3.4 directory

7. Update Snap Creator Agent on remote servers

8. Remove old 3.3 directories

Is that all I need?  Just want to ensure I have the VARs needed and the process correct.

Thanks for the help -

SnapCreator Upgrade from 3.3 to 3.4

Yep that is about right

For SC 3.3.0 to SC 3.4.0 both Agent and Server must be upgraded.

The only thing maybe missing is the GUI scheduler. I am going to check with some of the other devs if there is a way to copy the DB tables it uses over otherwise you need to re-create all the schedules in the GUI. If you aren't using them ignore this. We are going to improve this in the future.

Regards,

Keith

SnapCreator Upgrade from 3.3 to 3.4

Thanks Keith,

I am currenlty not using the GUI schedular in 3.3 but was thinking about it for 3.4.  For now, everything is scheduled via cron.

For the GUI schedular, is the GUI required to be running via '/usr/bin/java -jar snapcreator.jar -gui_port 6060'; in order for the jobs to run?  Just curious as cron is running as a deamon, I would imagine the java process must be running to manage the GUI schedular jobs.

SnapCreator Upgrade from 3.3 to 3.4

Hi Keith,

Yes we can port the DB tables created in 3.3 to 3.4.

1. Install the SnapCreator server.

2. If you have selected "Start server as service", then go to Windows services and stop the service "SnapCreatorServerService" and delete <scServer Home>/gui/snapcreator folder.

3. copy <scServer 3.3 home>/gui/snapcreator folder to <scServer 3.4 home>/gui/

4. copy the content of configs folder to <scServer 3.3 home>/configs except "default" folder. If you copy "default" folder, you might loose some of the new features while creating new config.

5. restart the server using java -jar snapcreator.jar -gui_port. If snapcreator is installed as service, then go to Windows services and start the service "SnapCreatorServerService".

Little manual work is required in this case.

regards

SnapCreator Upgrade from 3.3 to 3.4

We did the upgrade in the same way, added the variables to our existing configs, copied the schedule-database, changed the startup scripts, upgraded the agents (and also changed them to run multithreaded). Everything seems to be running fine, but we have a big problem: scServer cannot reach any scAgent...

It throws a java exception like this:

"Caused by: java.net.SocketException: SocketException invoking http://rs24.asp.local:9089/SnapCreator/Daemon/Agent: Unexpected end of file from server"

I also tried changing the agent back to single threaded, but that makes no difference. So... help?

SnapCreator Upgrade from 3.3 to 3.4

Can you telnet to agent:port "telnet rs24.asp.local 9089" from scServer?

Also a java error is very strange? The snapcreator binary meaning the agent and the backend server is not written in Java. Please try things from CLI to rule out Java.

The only place I could imagine you seeing a java error is if you do an agent ping from GUI since that java client in that case talks to agent. But snapcreator server binary to snapcreator agent binary = NO JAVA CODE.

Another thing check the /scAgent3.4.0/config/agent.conf? Make sure if you had any security things there from 3.3.0 that you update that, the agent.conf changed so please read about it. Here is what you should have:

############################################

### SnapCreator Agent Configuration File ###

############################################

######################################################################

### Command to allow or wildcard "*" can be used to allow anything ###

######################################################################

host: scServer@*

If you are running any commands or scripts through agent then you need to do something like this

############################################

### SnapCreator Agent Configuration File ###

############################################

######################################################################

### Command to allow or wildcard "*" can be used to allow anything ###

######################################################################

host: scServer@*

command: echo

command: snapdrive

command: script.sh

Regards,

Keith

~          

~          

SnapCreator Upgrade from 3.3 to 3.4

Yes, telnet from the server works fine. I checked the agent.conf: it was the original from the tar-file, but there were ^M charaters in the AIX version, so I removed them and restarted the agent, but it is still not reachable.

I need to clarify the java error: that shows up if I do a "test agent connection" from the web gui.

Running a profile from the command line gives this error:

[root@linux scServer3.4.0]# ./snapcreator --profile <profilename> --config <configname> --action snap --policy daily --verbose

########## Parsing Environment Parameters ##########

########## PRE APPLICATION QUIESCE COMMANDS ##########

[Fri Jul  1 11:02:32 2011] INFO: No commands defined

########## PRE APPLICATION QUIESCE COMMANDS FINISHED SUCCESSFULLY ##########

########## Application quiesce ##########

[Fri Jul  1 11:02:32 2011] ERROR: No valid response

[Fri Jul  1 11:02:32 2011] ERROR: [scf-00053] Application quiesce for plugin oracle failed with exit code 1, Exiting!

########## Application unquiesce ##########

[Fri Jul  1 11:02:32 2011] ERROR: No valid response

[Fri Jul  1 11:02:32 2011] ERROR: [scf-00054] Application unquiesce for plugin oracle failed with exit code 1, Exiting!

########## PRE EXIT COMMANDS ##########

[Fri Jul  1 11:02:32 2011] INFO: No commands defined

########## PRE EXIT COMMANDS FINISHED SUCCESSFULLY ##########

SnapCreator Upgrade from 3.3 to 3.4

Ok so this is consistent, it means the agent is not reachable which means there is some Network communication issues. Neither the GUI nor the CLI can talk to the agent. This can happen due to following:

1. Firewall (thought if you can telnet the port should be open)

2. Using the wrong agent port

3. Other Network issues

I am thinking maybe option 2? Are you sure you started agent on correct port? You are not using default port wich is 9090. Also are you sure the SC_AGENT setting is correct?

You can send us command you are using to start agent, the SC_AGENT setting in config file, and the output from your telnet command?

Please double check

Keith

SnapCreator Upgrade from 3.3 to 3.4

Oh another thing if you have ^M in agent.conf that means you probably edited it in windows and copied to unix, is that possible? If you didn't that means they were there wich would be a build issue on our edb. Let us know?

Double check and make sure there are no ^M in your config file. This would explain this issue since SC_AGENT would have ^M and that would mess things up.

If in doubt do this, vi config file, edit select all. Create new file in vi, and paste config there. Then use the new config file.

Regards,

Keith

Re: SnapCreator Upgrade from 3.3 to 3.4

Yes, we explicitly configured port 9089 for all agents, because 9090 is in use on AIX by the Web System Management daemon. I did find another thing: using telnet, I get a normal (open) connection if I use the single-threaded agent, but the connection is opended and closed immediately if I start the multithreaded agent.

As for the ^M: they are in the .tar.gz package on the NOW site, I did not change anything to the agent.conf file. Oh, and also, the files on NOW are not .tar.gz files, just plain .tar files. gunzip told me they were not in gz format, and tar would not unpack them if I used the -z option. And yes, I removed the ^M from the files.