Subscribe

SnapCreator and vSphere 5

[ Edited ]

Hi there,

Currently, SnapCreator is not able to gather the datastore list from vSphere 5 hosts/vCenter (vCenterDatastoreNotFoundException).

Is there a plan to add support for it? If so, is there already a timeline for it?

Thanks.

SnapCreator and vSphere 5

Yes, this will be fixed in the upcoming community release.

Until then, you can use try using CLI, or create/update the config manually.

Thanks,

Kapil

SnapCreator and vSphere 5

Hi there.

Is there a way, by using the CLI or manual config, to get SC to quisce the vSphere 5 VMs?

Regards.

SnapCreator and vSphere 5

Yes, you can do that.

Create a configuration using none option, just to select the filer details and other options.You can select any volume as vmware plugin is finally going to overwrite that.

Open the config file in a text editor and

1) update APP_NAME = vibe

2) Search for  VIBE Custom Settings and set the parameters as per the description.

Once done you can open the config in GUi and run as usual.

Hope this helps.

Thanks,

Kapil

Re: SnapCreator and vSphere 5

Hi,

By following your instructions I was able to setup it and get my snapshots running.

But I now have a problem: the VMware snapshots created by Snap Creator are not being deleted after the snapshot creation.

As far as I can see, unquisce only checks the first VM in the inventory. No log entries are shown for any of the other VMs running on the host.

Can you help me on this?

Thanks.

SnapCreator and vSphere 5

Can you send the log file .out and .debug logs? Do you get an error somewhere?

Keith

Re: SnapCreator and vSphere 5

Hi Keith,

Here are some prints:

########## Application quiesce ##########

[Fri Sep 23 11:05:57 2011] INFO: Checking if VIBE pre-requisites already run (function: quiesce) ....

[Fri Sep 23 11:05:57 2011] INFO: Discovery already completed -- not re-running prerequisites.

[Fri Sep 23 11:05:57 2011] INFO: Creating vSphere snapshots (if applicable) ...

[Fri Sep 23 11:05:57 2011] DEBUG: Creating snapshot for VM vm1 ...

[Fri Sep 23 11:05:57 2011] DEBUG: Checking power state of VM vm1 ...

[Fri Sep 23 11:05:57 2011] INFO: Power state of VM vm1 is off, not taking snapshot.

[Fri Sep 23 11:05:57 2011] DEBUG: Creating snapshot for VM vm2 ...

[Fri Sep 23 11:05:57 2011] DEBUG: Checking power state of VM vm2 ...

[Fri Sep 23 11:05:57 2011] INFO: Power state of VM vm2 t is off, not taking snapshot.

[Fri Sep 23 11:05:57 2011] DEBUG: Creating snapshot for VM vm3 ...

[Fri Sep 23 11:05:57 2011] DEBUG: Checking power state of VM vm3...

[Fri Sep 23 11:05:57 2011] DEBUG: Checking snapshot capability of  VM vm3 ...

[Fri Sep 23 11:05:57 2011] DEBUG: Removing leftover snapshots for VM vm3 ...

[Fri Sep 23 11:05:57 2011] DEBUG: Creating snapshot of VM vm3 (attempt #1) ...

[Fri Sep 23 11:06:02 2011] DEBUG: Creation of snapshot for VM vm3 successful.

[Fri Sep 23 11:06:35 2011] INFO: Snapshot creation process completed successfully.

(...)

########## PRE APPLICATION UNQUIESCE COMMANDS ##########

[Fri Sep 23 11:06:38 2011] INFO: No commands defined

########## PRE APPLICATION UNQUIESCE COMMANDS FINISHED SUCCESSFULLY ##########

########## Application unquiesce ##########

[Fri Sep 23 11:06:38 2011] INFO: Checking if VIBE pre-requisites already run (function: unquiesce) ....

[Fri Sep 23 11:06:38 2011] INFO: Discovery already completed -- not re-running prerequisites.

[Fri Sep 23 11:06:38 2011] INFO: Removing snapshots (if applicable)

[Fri Sep 23 11:06:38 2011] DEBUG: Checking power state of VM vm1 ...

[Fri Sep 23 11:06:38 2011] INFO: Power state of VM vm1 is off, not taking snapshot.

########## POST APPLICATION UNQUIESCE COMMANDS ##########

[Fri Sep 23 11:06:38 2011] INFO: No commands defined

########## POST APPLICATION UNQUIESCE COMMANDS FINISHED SUCCESSFULLY ##########

(...)

########## NetApp Snap Creator Framework finished successfully ##########

[Fri Sep 23 11:06:38 2011] INFO: INFO: NetApp Snap Creator Framework finished successfully ( Action: snap )

[Fri Sep 23 11:06:38 2011] DEBUG: Exiting with error code - 0

Re: SnapCreator and vSphere 5

Snap Creator is not taking vmware snapshots so there are no vmware snapshots to delete

########## Application unquiesce ##########

[Fri Sep 23 11:06:38 2011] INFO: Checking if VIBE pre-requisites already run (function: unquiesce) ....

[Fri Sep 23 11:06:38 2011] INFO: Discovery already completed -- not re-running prerequisites.

[Fri Sep 23 11:06:38 2011] INFO: Removing snapshots (if applicable)

[Fri Sep 23 11:06:38 2011] DEBUG: Checking power state of VM vm1 ...

[Fri Sep 23 11:06:38 2011] INFO: Power state of VM vm1 is off, not taking snapshot.

The VM is powered off. If we detect VM is powered off we dont delete snapshots, so any snapshots created previously would also not be deleted.

The only time we create and delete vmware snapshots is when the VM is powered ON. If it is powered OFF there is no reason to take vmware snapshots as the VM is not running and is in a consistent state.

Hope this helps

Regards,

Keith

Re: SnapCreator and vSphere 5

I'm aware of that.

This is just a small subset of my VMs. My regular backup set consists in 10 powered on VMs and 5 powered off.

This set has 1 powered on VM (vm3) and 2 powered off.

Snap Creator creates the snapshots on the powered on VM, but does not remove it in the end.

This happens on my larger set as well.

You can see that from the log:

Snap creator never deletes the snapshot it creates for vm3.

[Fri Sep 23 11:05:57 2011] DEBUG: Checking snapshot capability of  VM vm3 ...

[Fri Sep 23 11:05:57 2011] DEBUG: Removing leftover snapshots for VM vm3 ...

[Fri Sep 23 11:05:57 2011] DEBUG: Creating snapshot of VM vm3 (attempt #1) ...

[Fri Sep 23 11:06:02 2011] DEBUG: Creation of snapshot for VM vm3 successful.

########## Application unquiesce ##########

--> !!!! You can't see anything related to vm2 here (should have an entry similar to vm1) !!!!! <--

--> !!!! You can't see anything related to vm3 here (should have the snapshot delete entry) !!!!! <--

In the end of the backup, the powered on vm3 will have a Snap Creator snapshot.

Regards.

Re: SnapCreator and vSphere 5

Ok like I said we need full logs

We will look at it, You should be able to attach logs somehow there is a way to attach things

This could be a bug, issue is we dont support vSphere 5 (yet), support is comming with next release so we havent done much testing against vSphere 5. We will help you either way so just get us logs and we will send it to our QA team. It might be a few days or week till we can test a mix of powered on and powered off VMs under vSphere 5.

One thing that would be interesting. Can you test what happens if you backup only VMs that are powered on? Does it then remove the VMware snapshot?

Regards,

Keith