Subscribe

SnapCreator upgrade issue 3.4.0 to 3.4p2

[ Edited ]

I just installed 3.4p2 on my LINUX host.  For the upgrade, I followed this process:

1) Stop Snap Creator Server of current installation.

2) Take a backup of the profiles under scServer3.4.0/configs folder

3) Take a backup of the Snap Creator database folder i.e scServer3.4.0/gui/snapcreator

4) Install new Snap Creator 3.4p2

5) Copy backed up profiles to the new scServer3.4p2/configs folder

6) Delete the newly created Snap Creator database folder i.e scServer3.4p2/gui/snapcreator

7) Copy the backed up Snap Creator database folder to i.e scServer3.4p2/gui directory

8) Start Snap Creator Server

Is there an upgrade option that is needed for snapcreator (i.e. for 3.5 needed to run: java -jar snapcreator.jar -upgrade)?

Any new profiles/configs created will 'not' run.  The existing schedules and oddly enough the existing configs run (by both CLI and using GUI); however, any new profiles/configs created via the GUI will not run.

I receive the following error when running from the CLI:

./snapcreator --profile SBW_DB2 --config SBW_ARCH2 --action snap --policy hourly --debug

Subroutine AUTOLOAD redefined at

        /</usr/local/netapp/NTAPscreator/scServer3.4p2/snapcreator>Net/SSLeay.pm line 651 (#1)

    (W redefine) You redefined a subroutine.  To suppress this warning, say

   

        {

        no warnings 'redefine';

        eval "sub name { ... }";

        }

   

Subroutine print_errs redefined at

        /</usr/local/netapp/NTAPscreator/scServer3.4p2/snapcreator>Net/SSLeay.pm line 688 (#1)

Subroutine die_if_ssl_error redefined at

        /</usr/local/netapp/NTAPscreator/scServer3.4p2/snapcreator>Net/SSLeay.pm line 704 (#1)

Subroutine die_now redefined at

        /</usr/local/netapp/NTAPscreator/scServer3.4p2/snapcreator>Net/SSLeay.pm line 712 (#1)

Subroutine blength redefined at (eval 251) line 1 (#1)

Can't load 'auto/Net/SSLeay/SSLeay.so' for module Net::SSLeay: auto/Net/SSLeay/SSLeay.so: cannot open shared object file: No such file or directory at /</usr/local/netapp/NTAPscreator/scServer3.4p2/snapcreator>DynaLoader.pm line 219.

at perlapp line 843 (#2)

    (F) The module you tried to load failed to load a dynamic extension. This

    may either mean that you upgraded your version of perl to one that is

    incompatible with your old dynamic extensions (which is known to happen

    between major versions of perl), or (more likely) that your dynamic

    extension was built against an older version of the library that is

    installed on your system. You may need to rebuild your old dynamic

    extensions.

   

Uncaught exception from user code:

        Can't load 'auto/Net/SSLeay/SSLeay.so' for module Net::SSLeay: auto/Net/SSLeay/SSLeay.so: cannot open shared object file: No such file or directory at /</usr/local/netapp/NTAPscreator/scServer3.4p2/snapcreator>DynaLoader.pm line 219.

at perlapp line 843

at perlapp line 950

        PerlApp::my_require('Net/SSLeay.pm') called at snapcreator.pl line 9046

        main::setEnv() called at snapcreator.pl line 581

Any ideas?

Thanks,

Jerry

Re: SnapCreator upgrade issue 3.4.0 to 3.4p2

RESOLVED:  I decided to totally remove any instance of Snap Creator from the server and then rebooted the system.  I then copied just the configs and the gui/snapcreator from another server.  The system appears to be running as it should now.   Not sure why perl was having the issue, maybe a zombie process on the server.

If you do see any issues with the upgrade process please let me know.

Thanks,

Jerry

Re: SnapCreator upgrade issue 3.4.0 to 3.4p2

I've just upgraded 3.4.0 to 3.4p2 to solve an issue with MANAGEMENT_INTERFACES that I see was resolved in p1. My upgrade process was somewhat similar, but I've kept the 3.4.0 version alongside.

I didn't have the gui server running so not had the issues with processes like you may have.

1. Installed 3.4p2 code alongside in /opt/netapp

2. Copied etc, configs and the snapcreator db     

     # cd scServer3.4p2/gui

     # cp -r ../../scServer3.4.0/gui/snapcreator/ ./

     # cp -r ../../scServer3.4.0/gui/etc/ ./

     # cd ../configs

     # cp -r ../../scServer3.4.0/configs/* ./

     # cd ..

3. Relicensed

     # ./snapcreator --profile setup

4. Reconfigured my cronjobs to use the new path

All good

Re: SnapCreator upgrade issue 3.4.0 to 3.4p2

Interestingly I received the same SSL error today.

Started thinking about what I did differently yesterday vs today.  I had a system setup as HTTPS then switched to HTTP yesterday.

Tested this again.  When I use HTTPS I receive the SSL error as described above...

Maybe an issue if you cannot authenticate via SSL to the NetApp...

Jerry

Re: SnapCreator upgrade issue 3.4.0 to 3.4p2

This is from BURT 499567

HTTPS may not work on linux out-of-the-box. This appears to mainly be issue with SuSe but really could apply to any Unix. Snap Creator does not include ssl libraries we are dependent on, therefore customer must install openssl and ensure symlinks are created correctly (see below). The reason is simply we dynamically link so customers can update SSL versions of openssl for important security fixes without being dependent on SC versions.

The requirements for HTTPS for Linux/Unix are as follows:

1) openssl package

2) SSL symlinks

Make sure the following symlinks are located under /usr/lib oder /usr/lib64 (depending on if OS is 64bit or not)

libssl.so.6

libcrypto.so.6

If the symlinks dont exist please cd to /usr/lib or /usr/lib64 and run following command to link them. Make sure what we are linking to is installed, again pre-requisite is openssl so it should be installed first.

ln -sf libssl.so.0.9.8 libssl.so.6

ln -sf libcrypto.so.0.9.8 libcrypto.so.6

If this doesn't work run strace and send to engineering:

strace ./snapcreator --profile <profile> --action snap --policy <policy> --verbose

Regards,

Keith

Re: SnapCreator upgrade issue 3.4.0 to 3.4p2

To get this working on Oracle Linux 6.2 the same symlinks needed to be created.