SnapManager® 5.1 for Microsoft® SQL Server®


I'm the DBA @ MundiPharma IT Services in Cambridge.

I've successfully installed a SQL Cluster/Snap Drive/Snap Manager.

I've set-up the backup jobs through the SnapMgr for SQL gui (they're windows scheduled tasks created via the gui) and all the jobs run fine.

However, whenever we create a new db on the sql box, SnapMgr does not detect the new db and therefore does not back it up.

I've tried accessing the windows task and added the new db, but this doesn't work -

"C:\Program Files\NetApp\SnapManager for SQL Server\SMSQLJobLauncher.exe" new-backup  –svr 'server1'  -d  'server1', '4', 'AdventureWorks2008R2', 'APPV', 'Blackberry', 'BMSStore' -ver  –verInst 'servername' -mp

–mpdir 'C:\Program Files\NetApp\SnapManager for SQL Server\SnapMgrMountPoint' -RetainBackups  8 -lb -bksif -RetainSnapofSnapInfo 8 -rubackups

8 –mgmt daily

The only way that I can find to get round this issue is to re-create the backup with SnapMgr gui.

When I create a new db, it shows the new db along with the other dbs already backed-up in the backup pane of SnapMgr, but all of the check boxes are unticked.

Other research - suggests to use the -C switch .

Is there something in the GUI to cover all future dbs?

Do I need to issue a command outside of the gui?



Re: SnapManager® 5.1 for Microsoft® SQL Server®

Whenever you add a new DB you need to re-run the configuration wizard from SMSQL.

SMSQL has to update the backup list and hence it has to re-run the config wizard.