Subscribe

SnapManager for SQL Server Version: 7.0.0.1799

[ Edited ]

Hi,

I can run database backups using the gui, but when i try to create a SQL server job, or cut and paste the command into SnapManager for SQL Server Powershell, I get an error that it cannot find any valid databases to be backed up.

This is my syntax:

PS C:\Program Files\NetApp\SnapManager for SQL Server> new-backup  -svr 'RSMIOSQLSTG1'  -d  'RSMIOSQLSTG1', '3', 'master', 'model', 'msdb' -RetainBackups  7 -RetainShareBackups  7 -cpylgbkshare NOTHING_TOSHARE -lb -bksif -RetainSnapofSnapInfoDays 1 -rubackups 1 -gen -mgmt standard

Here is the error I get:

[RSMIOSQLSTG1] Error Code: 0xc0040900

Unable to find any valid databases to be backed up.

[RSMIOSQLSTG1] Preparing for sending filer AutoSupport...

An Error occurred in the backup process.Please verify the results.

Details : Error Code: 0xC0040900 Unable to find any valid databases to be backe

d up.

new-backup : The new-backup has completed with errors.

At line:1 char:1

+ new-backup  -svr 'RSMIOSQLSTG1'  -d  'RSMIOSQLSTG1', '3', 'master', 'model',

'ms ...

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

~~~

    + CategoryInfo          : InvalidResult: (SMSQLPSSnapIn.SMSQLBackup:SMSQLB

   ackup) [new-backup], Exception

    + FullyQualifiedErrorId : Error: new-backup,SMSQLPSSnapIn.SMSQLBackup

new-backup : The Backup operation completed with errors.Please check the

SnapManager Reports/Windows EventLogs for more information.

At line:1 char:1

+ new-backup  -svr 'RSMIOSQLSTG1'  -d  'RSMIOSQLSTG1', '3', 'master', 'model',

'ms ...

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

~~~

    + CategoryInfo          : OpenError: (SMSQLPSSnapIn.SMSQLBackup:SMSQLBacku

   p) [new-backup], Exception

    + FullyQualifiedErrorId : [new-backup completed with errors],SMSQLPSSnapIn

   .SMSQLBackup

Re: SnapManager for SQL Server Version: 7.0.0.1799

Michael,

Thank you for taking the time to post your question to the NetApp Public Forums. Here are a few things I would explore and verify before escalating further.

Are you starting your Powershell session in administrator mode? I have been guilty of this in the past, and it is a great starting point.

You mentioned you copied and pasted the command. Please replace your hyphens from within your PS session. What I mean is, delete your hyphens and replace them with fresh hyphens. I have seen where the copy and paste functionality can misbehave. Although it looks correct, the Powershell passes the 'copied' hyphen as a different code causing unpredictable results. The cause of this could be many different environmental factors.

MICHAEL.CARAMAT wrote:

Here is the error I get:

[RSMIOSQLSTG1] Error Code: 0xc0040900

Unable to find any valid databases to be backed up.

[RSMIOSQLSTG1] Preparing for sending filer AutoSupport...

An Error occurred in the backup process.Please verify the results.

Details : Error Code: 0xC0040900 Unable to find any valid databases to be backe

d up.

new-backup : The new-backup has completed with errors.

At line:1 char:1

+ new-backup  -svr 'RSMIOSQLSTG1'  -d  'RSMIOSQLSTG1', '3', 'master', 'model',

'ms ...

If your backup is still not going, one could argue that it is connecting to the SQL server, but cannot read/connect to any of the databases. What user is configured for your sql agent service for that instance? The backup will execute as that user, please verify that this user has the proper access from within your SQL Managment tools at the database level.

To verify your syntax and other Powershell commands, check out this page. If you plan to create backup scripts, you will need to review your execution policies to allow unsigned PS scripts.

If you still run into issues, I would suggest reviewing your windows logs, SQL Managment logs, enabling debug logging for SMSQL and reviewing your autosupport for additional messages from your filer. Additional environmental configuration will be required to further troubleshoot.

Posting your technical questions to the support community will get your questions in front of a much more focused technical audience.

I hope this helps! Let me know if you have any questions.

Thanks

David

Re: SnapManager for SQL Server Version: 7.0.0.1799

David,

I think I found my issue, but have a question. When I go to “Add Managed Servers” in SnapManager with a local SQL Server database account, I can see the list of databases. But when I try it with a domain account, no databases are displayed. I also verified that the domain account has sysadmin rights in the SQL server instance. Have you seen this behavior?

Re: SnapManager for SQL Server Version: 7.0.0.1799

Michael,

The fact that you can see the databases with the local service account does offer some clues.

Are you able to connect to the SQL Management Studio with your domain account and view/access your databases? This will verify that the SQL server is configured for MIXED mode and the user has proper permissions. This user will need admin privilege on the SQL host to access the file system and write to the registry.

Are you accessing Snap Manager locally from the SQL Server, or is this configured for remote administration on a different host? If remote, are there any firewall considerations blocking port 808 by group policy that may not affect your local account? Try disabling the firewall or creating a rule for the Snap Manager port TCP 808.

Which account do you have configured for the Snap Manager for SQL service? Local or domain? Configure as the domain account and test.

How about the SQL Server service? What version of SQL server are you working with? Is this in a production environment? Stand-alone or a part of a SQL cluster? Is this in a virtualized environment?

Check out the administrator’s guide for further details - https://library.netapp.com/ecm/ecm_download_file/ECMP1217281

Please let me what you come up with, I’m here to help!

Thanks

David Hesford

Re: SnapManager for SQL Server Version: 7.0.0.1799

I found the answer. I needed to give the account that the snap manager service runs under sysadmin rights in the SQL server instance. Thanks for your help.