Subscribe

Snapcreator, Xen plugin backup problems

[ Edited ]

After creating some confguration to backup our VMware environment with Snapcreator I am now trying to backup our Xenserver environment.

However I am unsuccesful in creating a backup. When i run the backup job I get the following error :

[2014-04-27 22:00:22,308] ERROR: [ap-gda01-nascf.its.centric.lan:9090(4.1.1.1)] SCF-00028: Auto Discovery for plug-in [xen] failed with error [validation failed] and exit code [1], Exiting!

[2014-04-27 22:00:22,311] DEBUG: Workflow : backup_OnFailure started with workflow id : 979

Can anybody shed some light as to what is going wrong here, it looks like it can't connect to the xenserver or something (?) but i could add the xen servers to the configuration and select the vm's to backup, so that shouldn't be a problem..

Re: Snapcreator, Xen plugin backup problems

Hello,

Is this 7mode or cDOT?

If cDOT, are you using junction paths?

Are you using DFM?

Where is the agent running? Is it running before and after this error message? (or does it die?)

Could you please get a scdump and email to sivar at netapp.com?

Thanks,
Siva Ramanathan

Re: Snapcreator, Xen plugin backup problems

I've send you an email with the relevant information and the scdump file.

Re: Snapcreator, Xen plugin backup problems

Thank you for the email.

I saw APP_AUTO_DISCOVERY=Y in the config file.

Could you please try with

VOLUMES=auto:detect

and try a backup again?

Also, I see these 2 errors in the error log.

[2014-04-25 13:52:29,449] ERROR: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Fri Apr 25 13:52:25 2014) [xen-00003] Failed to get host instance with address xen-gda01.its.centric.lan

[2014-04-25 13:52:29,449] ERROR: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Fri Apr 25 13:52:25 2014) [xen-00055] Volume discover operation failed for the host : xen-gda01.its.centric.lan

Are you able to ping xen-dga01.its.centric.lan from the agent host? (ap-gda01-nascf.its.centric.lan)

Also, could you please try with the hostname instead of IP in both XEN_HOST_USERS and XEN_VMS?

You might also want to try with one VM first and then add the other VMs.

Is plink installed in the Snap Creator Agent host?

On Windows based Snap Creator Agent hosts, plink.exe is used to run ssh calls to the XENserver

Thanks,

Siva Ramanathan

Re: Snapcreator, Xen plugin backup problems

I added the VOLUMES=auto:detect option, but that didn't help

The errors about failed to get host instances are old errors and not applicable anymore, and i am able to ping the xen-gda01 server from the agent host.

When i modify the configuration and change the IP addresses to the hostname the following errors show up in the logging:

[2014-04-30 07:28:15,919] INFO: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:08 2014) Performing discover operation in xen plug-in

[2014-04-30 07:28:15,919] INFO: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:08 2014) Creating executor for the filer  na-gda00-xen

[2014-04-30 07:28:15,919] DEBUG: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:08 2014) Parsing NTAP_USERS - filer: na-gda00-xen user: scfadmin

[2014-04-30 07:28:15,919] INFO: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:12 2014) Creating executor for the filer  na-mdt00-sv-gda

[2014-04-30 07:28:15,919] DEBUG: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:12 2014) Parsing NTAP_USERS - filer: na-mdt00-sv-gda user: scfadmin

[2014-04-30 07:28:15,920] INFO: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:13 2014) Creating executor for the filer  na-gda00-xen.its.centric.lan

[2014-04-30 07:28:15,920] DEBUG: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:13 2014) Parsing NTAP_USERS - filer: na-gda00-xen.its.centric.lan user: scfadmin

[2014-04-30 07:28:15,920] INFO: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:13 2014) Performing volume discover operation for HOST : xen-gda01

[2014-04-30 07:28:15,920] INFO: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:13 2014) Creating XEN RPC session on host : xen-gda01

[2014-04-30 07:28:15,920] INFO: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:13 2014) Getting the host instance and record information from host xen-gda01

[2014-04-30 07:28:15,920] INFO: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:13 2014) Found host with address 10.15.3.10

[2014-04-30 07:28:15,920] INFO: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:13 2014) Found host with address 10.15.3.11

[2014-04-30 07:28:15,920] ERROR: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:13 2014) [xen-00003] Failed to get host instance with address xen-gda01

[2014-04-30 07:28:15,921] ERROR: [ap-gda01-nascf.its.centric.lan:9090 (4.1.1.1)] (Wed Apr 30 07:28:13 2014) [xen-00055] Volume discover operation failed for the host : xen-gda01

[2014-04-30 07:28:15,921] ERROR: [ap-gda01-nascf.its.centric.lan:9090(4.1.1.1)] SCF-00028: Auto Discovery for plug-in [xen] failed with error [validation failed] and exit code [1], Exiting!

[2014-04-30 07:28:15,924] DEBUG: Workflow : backup_OnFailure started with workflow id : 1022

Even though the manual states that plink.exe is used in Fiber environments i installed it in C:\windows\system32 (so it's in the path), but that also didn't change anything.

For Fibre Channel in a Storage Area Network (SAN) environment, the plink.exe tool must be

installed on a host where the Snap Creator agent is installed, and the plink.exe path must be

added to the system environment variable

Re: Snapcreator, Xen plugin backup problems

Siva,


Is there anything else I could try? I still can't backup our Xen enviroment, and I still haven't got a clue why

Re: Snapcreator, Xen plugin backup problems

Siva,

is there anything we need to collect in terms of logs, or any changes we need to make in order to drive this issue to a close?